Introduction

Dovetail Email Agent is Dovetail Software's email processing engine. It is a Windows Service that periodically checks a POP3 mailbox for new mail messages and processes them according to configurable rules. This allows employees and/or customers to perform operations against a Clarify™ database by simply sending an email.

Because Dovetail Email Agent uses the Dovetail SDK for Clarify to directly access the Clarify™ database, Dovetail Email Agent can support internationalized data (both incoming and outgoing) in Unicode and UTF-8 format (among others), thus making it fully internationalized.

In This Chapter

Overview

Features

Getting Help

Next

Overview
Introduction

Did this topic help you? Email us your feedback.
Last updated: 10/8/2007 4:25:05 PM
© by Dovetail Software, Inc.


Overview

Dovetail Email Agent operates in three distinct email parsing modes, described in this section:

  • Freeform Mode
  • API Invoke Mode
  • EEO Redirect Mode

See Also

Introduction

Features

Getting Help

Next

Freeform Mode
Overview

Did this topic help you? Email us your feedback.
Last updated: 10/3/2007 11:21:39 AM


Freeform Mode

In Freeform Mode, Dovetail Email Agent will scan the contents of an incoming email for a particular and configurable set of words that will identify this email as a reply to an existing case in the Clarify™ system. If these words are found, Dovetail Email Agent will log this email as notes against that case or subcase. Otherwise, it will create a new case using the email text as log notes. It will optionally create a contact based on the "FROM:" email address if one does not already exist.

See Also

Overview

API Invoke Mode

EEO Redirect Mode

Next

API Invoke Mode
Freeform Mode

Did this topic help you? Email us your feedback.
Last updated: 1/4/2008 3:52:32 PM


API Invoke Mode

In API Invoke Mode, Dovetail Email Agent invokes requested APIs and returns the results in a reply email. Dovetail Email Agent can be configured to execute custom-built APIs (provided they adhere to a few requirements), or it can execute API toolkits purchased from Dovetail Software, such as the Clear Support toolkit.

See Also

Overview

Freeform Mode

EEO Redirect Mode

Next

EEO Redirect Mode
API Invoke Mode

Did this topic help you? Email us your feedback.
Last updated: 1/4/2008 3:51:46 PM


EEO Redirect Mode

NOTE: EEO Redirect Mode requires a separate license from Dovetail Email Agent. Please contact Dovetail Software to talk about this product and discuss licensing options.

In EEO Redirect Mode, Dovetail Email Agent will process specially marked messages sent from the Dovetail Enhanced Email Out product and re-send them using a different, configurable "FROM:" address. This allows you have all outgoing support emails appear to come from the same email address (i.e. support@yourcompany.com).

See Also

Overview

Freeform Mode

API Invoke Mode

Next

Features
EEO Redirect Mode

Did this topic help you? Email us your feedback.
Last updated: 1/4/2008 3:51:06 PM


Features

This section describes some of Dovetail Email Agent's major features.

See Also

Introduction

Overview

Getting Help

Next

Runs as a Windows Service
Features

Did this topic help you? Email us your feedback.
Last updated: 1/4/2008 3:54:03 PM


Runs as a Windows Service

Dovetail Email Agent is a full Windows Service and runs just like other Windows services. It can be configured to log on as any user. It will start automatically when the computer starts and, most importantly, it does not require a user to be logged on to the console.

Also, you can install multiple Dovetail Email Agent services on a single computer. For more information, see the Running multiple services section.

See Also

Features

Secure

POP3 and SMTP-based

Customizable Outgoing Email Templates

Flexible Case ID Number Scheme Handling

Enhanced Logging and Auditing

Unicode Support

Next

Secure
Runs as a Windows Service

Did this topic help you? Email us your feedback.
Last updated: 1/4/2008 3:54:29 PM


Secure

Dovetail Email Agent was designed with security as a top priority. It will run with very few privileges and is designed to run as the 'Network Service' user on XP and later as recommended by Microsoft for services such as Dovetail Email Agent. In fact, on Windows XP and later, Dovetail Email Agent doesn't even have the privileges to write log files unless specifically granted by the administrator of the computer.

For more information about security considerations when using Dovetail Email Agent, see the Security Considerations section.

See Also

Features

Runs as a Windows Service

POP3 and SMTP-based

Customizable Outgoing Email Templates

Flexible Case ID Number Scheme Handling

Enhanced Logging and Auditing

Unicode Support

Next

POP3 and SMTP-based
Secure

Did this topic help you? Email us your feedback.
Last updated: 10/2/2007 2:02:12 PM


POP3 and SMTP-based

Dovetail Email Agent requires no additional software to be installed on the server (other than the .NET Framework) and connects directly to any POP3 and SMTP server. POP3 and SMTP are the two main email standards which all Internet email servers must implement in order to interact with each other. This allows Dovetail Email Agent to work against whichever email solution your organization has chosen to install (including Unix™ and Linux mail servers as well as other Windows-based email servers).

See Also

Features

Runs as a Windows Service

Secure

Customizable Outgoing Email Templates

Flexible Case ID Number Scheme Handling

Enhanced Logging and Auditing

Unicode Support

Next

Customizable Outgoing Email Templates
POP3 and SMTP-based

Did this topic help you? Email us your feedback.
Last updated: 10/3/2007 11:23:22 AM


Customizable Outgoing Email Templates

Dovetail Email Agent uses the XML templating standard "XSLT" to create the email body which it will send to customers when generating outbound emails. This provides a powerful and flexible mechanism which allows the email bodies to be fully customizable using either plain-text or HTML formatting -- allowing for branded emails which is important for consistency in any organization.

See Also

Features

Runs as a Windows Service

Secure

POP3 and SMTP-based

Flexible Case ID Number Scheme Handling

Enhanced Logging and Auditing

Unicode Support

Next

Flexible Case ID Number Scheme Handling
Customizable Outgoing Email Templates

Did this topic help you? Email us your feedback.
Last updated: 10/2/2007 2:02:22 PM


Flexible Case ID Number Scheme Handling

Dovetail Email Agent can support a wide range of custom case ID numbering schemes. For more information on adapting Dovetail Email Agent to properly process your custom case ID scheme, see the section on using custom case ID number schemes with Dovetail Email Agent.

See Also

Features

Runs as a Windows Service

Secure

POP3 and SMTP-based

Customizable Outgoing Email Templates

Enhanced Logging and Auditing

Unicode Support

Next

Enhanced Logging and Auditing
Flexible Case ID Number Scheme Handling

Did this topic help you? Email us your feedback.
Last updated: 10/2/2007 2:02:28 PM


Enhanced Logging and Auditing

Dovetail Email Agent takes advantage of the powerful and flexible logging features built into the Dovetail SDK. This makes it easier to troubleshoot and diagnose problems that may arise as well as audit and monitor the health of Dovetail Email Agent. Logging settings can be changed on-the-fly at runtime without having to stop the service and restart it. Changes are seen immediately.

Also, Dovetail Email Agent has the option of archiving every email received and sent for debugging, auditing, or tracking purposes. For more information, see the Email Tracking section.

See Also

Features

Runs as a Windows Service

Secure

POP3 and SMTP-based

Customizable Outgoing Email Templates

Flexible Case ID Number Scheme Handling

Unicode Support

Next

Unicode Support
Enhanced Logging and Auditing

Did this topic help you? Email us your feedback.
Last updated: 10/2/2007 2:02:35 PM


Unicode Support

Dovetail Email Agent accepts incoming emails in many different encodings and sends out email using Unicode (UTF-8) formatting. For more information on configuring your Clarify™ database to accept Unicode data, please consult the Dovetail SDK documentation section on "Enabling Unicode Data Storage".

Outgoing email that Dovetail Email Agent sends out is generated using XSLT templates which can be customized. These customizations can include Unicode characters. An example would be a template that is all in Japanese for Japanese customers.

Unicode supports most human written languages and other forms of written expression. This includes, but is not limited to, Asian (Chinese, Japanese, Korean, etc), Middle-East (Hebrew, Arabic, Farsi, etc), Cyrillic, Slavic, and many more character sets.

See Also

Features

Runs as a Windows Service

Secure

POP3 and SMTP-based

Customizable Outgoing Email Templates

Flexible Case ID Number Scheme Handling

Enhanced Logging and Auditing

Next

Getting Help
Unicode Support

Did this topic help you? Email us your feedback.
Last updated: 10/2/2007 2:02:40 PM


Getting Help

If you need additional help beyond this user guide, you can use any of the following resources:

  • Dovetail SelfService - Use our online customer support site to notify us of a support issue, to manage your Dovetail products, to seek sales support, or to search the knowledge base.
  • Knowledge Base Articles - Search our online knowledge base for existing issue resolutions.
  • Product Documentation - Find Dovetail's most up-to-date product documentation.
  • Blog Posts - Dovetail developers often publish useful posts about Dovetail Email Agent
  • Contact Us - Contact us directly if you need further assistance.
    • support@dovetailsoftware.com
    • phone 800-684-2055 or 512-610-5400

See Also

Introduction

Overview

Features

Next

What’s New
Getting Help

Did this topic help you? Email us your feedback.
Last updated: 1/5/2011 5:07:18 PM


What’s New

In This Chapter

Version 1.6.4

Version 1.6.3

Version 1.6.2

Version 1.6.1

Version 1.6

Version 1.5.3

Version 1.5.2

Version 1.5.1

Version 1.5.0

Version 1.4.7

Version 1.4.6

Version 1.4.5

Version 1.4.4

Version 1.4.3

Version 1.4.2

Version 1.4.1

Version 1.4

Version 1.3

Version 1.2

Version 1.1

Version 1.0.9

Version 1.0.8

Version 1.0.7

Version 1.0.6

Version 1.0.5

Version 1.0.4

Version 1.0.3

Version 1.0.2

Version 1.0.1

Version 1.0.1

Version Beta 1 (0.9)

Next

Installation Guide

Version 1.6.4

API Invoke Mode now better handles spaces and line returns when parsing out sub tags from an email body.

Version 1.6.3

Added an event log (33) for the rare occurrence of an out of memory exception being thrown during free form email processing.

Version 1.6.2

Dovetail Email Agent should now shutdown after an out of memory exception has been received.

Added better logging of email file attachments and their files sizes.

Version 1.6.1

Fixed a problem where the windows service could stop when attempting to process a Delivery Status Notification (DSN) message.

When using APIInvoke mode custom APIs are given a session from the Dovetail SDK. After each API invocation we now close all generics left open on this session. This change should enhance performance for custom APIs that are not cleaning up after themselves.

Version 1.6

In this release we focused on adding support for Amdocs 6 thru Amdocs 7.5.

No changes to the email processing were required, but Dovetail SDK has been updated since it was upgraded to support the new database enhancements.

Version 1.5.3

Dovetail Email Agent now does a better job of cleaning up after processing email messages.

Version 1.5.2

To prevent email loops Dovetail Email Agent now supports guidance from RFC 3834. All outgoing emails have their Auto-Submitted field set to "auto-response". More importantly any emails received with the Auto-Submitted field set to any value but "no" will be ignored. The goal of this behavior is to prevent automated responses such as auto or out of office replies from creating email loops. Details about ignored auto submitted emails are logged.

Fixed bug. Logging email in was not supporting additional fields settings.

The AllowLogEmailInToClosedSubcase setting was not being honored.

Version 1.5.1

Corrected a bug in the Dovetail SDK. The before and after Case/Subcase Status relations for an email log were not being set correctly. The LogCaseEmailIn and LogSubCaseEmailIn APIs are being used internally by Email Agent, so it has been updated to supply the correct logging functionality.

The Case/Subcase history was also corrected within the APIs to not include the Sender or Recipient properties from an email, since these are usually represented by the From and To properties.

Version 1.5.0

Corrected a bug with the case history created when saving whole email attachments. Duplicate attachments with the same file name would cause a link to the original attachment to appear in the case history.

Breaking Changes

Email Agent now logs "Email In" events to a case rather than logging a note. This change will mainly affect customers using our Rule Manager product having business rules that are setup to fire on "Log Notes" events, in particular those that are meant to capture "Log Notes" events created by Email Agent. Affected business rules should be changed to include a start event of "Email In".

To avoid confusion the name of configuration settings and template files related to Note Logs have been renamed to represent the move to creating Email In Logs.

Configuration Setting Changes

Basically every setting that mentions "LogNote" now says "LogEmailIn".

  • allowFreeFormLogNote changed to allowFreeFormLogEmailIn
  • reopenCaseToLogNotes changed to reopenCaseToLogEmailIn
  • allowLogNotesToClosedCases changed to allowLogEmailInToClosedCases
  • allowLogNotesToClosedSubcases changed to allowLogEmailInToClosedSubcases
  • sendLogNotesSuccessReply changed to sendLogEmailInSuccessReply
  • <logCaseNoteExtraFields/> changed to <logCaseEmailInExtraFields/>
  • <logCaseNoteExtraFields/> changed to <logSubcaseEmailInExtraFields/>

Template File Name Changes

  • FreeformCaseNoteFailure.xslt changed to FreeformCaseEmailInFailure.xslt
  • FreeformCaseNoteSuccess.xslt changed to FreeformCaseEmailInSuccess.xslt
  • FreeformClosedCaseNoteFailure.xslt changed to FreeformClosedCaseEmailInFailure.xslt
  • FreeformSubcaseNoteFailure.xslt changed to FreeformSubcaseEmailInFailure.xslt
  • FreeformSubcaseNoteSuccess.xslt changed to FreeformSubcaseEmailInSuccess.xslt
  • FreeformWontLogNote.xslt changed to FreeformWontLogEmailIn.xslt

    Also, please be aware that the version of the Dovetail SDK being used by Email Agent has been updated to supply the new Email In logging functionality.

Version 1.4.7

When saving saving whole emails as attachments, emails containing only plain text are now converted to HTML before being saved. This is to work around a problem viewing saved emails using Microsoft Word 2003 or 2007.

Version 1.4.6

Fixed an error preventing the formatting of notification emails when non-printable ASCII characters are present in the message being sent. Characters that are illegal in XML documents are now stripped from the message before being transformed.

Version 1.4.5

Added a new freeform mode feature which when enabled saves each incoming email as an attachment to the case. See the saveWholeEmailAsDovetailAttachment.Enabled configuration setting for more information.

There are two related configuration settings:

  1. saveWholeEmailAsDovetailAttachment.FileExtension - allows control of the file extension used for the email attachment.
  2. saveWholeEmailAsDovetailAttachment.HistoryAppenderTemplate - allows adding information about the saved email to case or subcase history.

Note: We now support more flexible handling of white space in configuration settings. The email-agent-config.xml configuration file <param> elements will now use the XML element text when a value attribute is not present.

Parameter Value as an attribute:

<param name="setting" value="parameter value"/>

Parameter Value as an element value:

<param name="setting">
    parameter value
</param>

In the example above the white space including line returns will be present in the parameter value

Version 1.4.4

The Dovetail SDK used by Email Agent has been updated to correct a problem with extra fields on created cases not honoring createCaseExtraFields configuration.

Version 1.4.3

The installer now makes sure that adodb.dll is present in the installation path.

Version 1.4.2

Updated the version of the Dovetail SDK being used by Email Agent, to address a Clarify Client compatibility issue with datetime values on Microsoft SQL Server. Please see this knowledge base article for more information.

Because the Dovetail SDK toolkits assembly name has changed in this version from fcSDK to Fchoice.Foundation.Clarify.Toolkits.Compatibility, the tags.xml has been updated to match the new assembly name.

Note: If you have customized your tags.xml page to include additional Dovetail SDK toolkit API's, you must update your tags.xml to reflect this change.

Version 1.4.1

Fixed a bug that prevented multiple Dovetail Email Agent services from running on the same machine. See Running Multiple Dovetail Email Agent Services for more information about this option.

Version 1.4

  • The product name has been changed. Formerly, it was named SuperEmailClerk.NET, sometimes abbreviated as SEC.NET. It is now Dovetail Email Agent.
  • A new configuration setting (allowFreeformCaseCreate) has been added which controls whether new cases can be created.
  • A new configuration setting (allowFreeformLogNotes) has been added which controls whether notes are allowed to be added to a case or subcase.

Version 1.3

  • A new configuration setting (allowLogNotesToClosedSubcases) has been added which controls whether notes are allowed to be added to a closed subcase.
  • A new configuration setting (processDSNMessages) has been added which controls whether or not Delivery Status Notification Messages are processed.
  • A new configuration setting (sendReplyToDsnMessages) has been added which controls whether or not a reply will be sent as a result of a Delivery Status Notification Message.

Version 1.2

A new configuration setting (allowLogNotesToClosedCases) has been added which controls whether notes are allowed to be added to a closed case.

Version 1.1

  • Requirement Change: Dovetail Email Agent is now built on the .Net 2.0 framework. It is now required that the .Net 2.0 framework is installed.
  • Dovetail Email Agent now supports a plug-in for custom contact validation when creating a case in freeForm mode. This allows customers to add custom validation code to validate whether a contact is allowed to create a case or not. See the Custom Contact Validation section for more details.

Version 1.0.9

General:

  • Optional configuration parameter sessionLocalTimezone was added to allow setting the timezone under which the service's ClarifySession will execute. This is important to set when the Clarify database and Dovetail Email Agent are located in different timezones. See the sessionLocalTimeZone parameter in the Dovetail Email Agent Configuration section for more details.

Fixes:

  • Bug fixed in Dovetail SDK to ensure that database datetimes are used where appropriate. Note: This version of Dovetail SDK (2.2.1.16) is a patch release.

Version 1.0.8

General:

  • Dovetail Email Agent is now using version 2.2.1 of the Dovetail SDK.

Fixes:

  • Return values from API invokes were not being relayed in invocation successful emails.
  • API Invoke mode was not working correctly due to mis-named assembly name in tags.xml

Version 1.0.7

General:

  • The platform dependencies of Dovetail Email Agent have been upgraded to support the Dovetail SDK. Please see the Dovetail SDK documentation for information on what's new.

New Features:

  • Added a new configuration parameter: sendLogNotesSuccessReply. This parameter allows you to control whether success replies are sent out when notes are logged to a case as a result of an incoming email. This gives more fine-grained control over email responses. For more information on this parameter, please refer to the Basic Configuration Guide and look up the sendLogNotesSuccessReply parameter.

Fixes:

  • Emails with large attachments are handled better and result in a smaller memory footprint. This helps avoid OutOfMemoryException conditions.

Version 1.0.6

General:

  • The platform dependencies of Dovetail Email Agent have been upgraded to support the new Dovetail SDK 2.0. Please see the Dovetail SDK documentation for information on what's new.

New Features:

  • BREAKING CONFIGURATION CHANGE
    The attachUseSubFolders parameter in the email-agent-config.xml file is no longer used. A new mode for storing attachments to cases has been added in this version of Dovetail Email Agent. This makes three different modes in which attachments can be saved. A new parameter called attachFolderMode has been added to the email-agent-config.xml to replace and extend the functionality of attachUseSubFolders.

    Please convert your configuration files. To convert, replace the use of attachUseSubFolders like this:
    • If you had the value set to FALSE, replace the config entry with this:
      <param name="attachFolderMode" value="ModeA"/>
    • If you had the value set to TRUE, replace the config entry with this:
      <param name="attachFolderMode" value="ModeB"/>
    • If you wish to use the new mode, replace the config entry with this:
      <param name="attachFolderMode" value="ModeC"/>

    For more information on what the three modes do and how to configure them, please refer to the Basic Configuration Guide and look up the attachFolderMode parameter.

Fixes:
EEO Redirect:

  • An erroneous warning (about the Dovetail Email Agent service shutting down when it really is not) was mentioned in an admin general alert sent by the eeoredirect processor in certain circumstances.
  • An eeoredirect failure reply was being sent, regardless of the sendFailureReply configuration setting, when there were "bad" recipients (LDAP errors, rejected by SMTP server, missing, etc).
  • An eeoredirect message with an invalid SMTP recipient could result in the invalid recipient showing up as both a rejected and accepted recipient in the Dovetail Email Agent failure reply.
  • X.400/LDAP resolution exceptions were not being logged.

Version 1.0.5

New Features:

  • Dovetail Email Agent's FCFL.NET dependencies have been upgraded to the latest version (1.2.1). Please see the FCFL.NET documentation for what's new in the 1.2.1 release.

    IMPORTANT CHANGE: The system requirements for this 1.0.5 build have been updated to require FCFL.NET 1.2.1. There have been significant changes to the FCFL.NET installation procedure. PLEASE REVIEW THE FCFL.NET 1.2.1 INSTALLATION GUIDE BEFORE INSTALLING EITHER FCFL.NET OR Dovetail Email Agent.

  • Added a configurable ignored emails list to allow you to configure from which email addresses Dovetail Email Agent will accept email. Please see the documentation on configuring Dovetail Email Agent to learn how to use this new feature.

Fixes:
General:

  • Fixed a memory leak in the FCFL.NET Platform Adapter for Dovetail Email Agent. The ClarifySession reference was not getting recycled, so the DataTables created by ClarifyGenerics were building up.
  • Added a unique identifier to the special X-FC-SentBySECNET loop-checking MIME header to avoid problems when emails are sent from one Dovetail Email Agent instance to another.
  • Added special handling for situations where the POP3 poll internal is set very fast (less than 10 seconds or so), or the system on which Dovetail Email Agent runs is frequently taxed (high CPU and/or memory utilization), to allow the .NET garbage collector and finalizer thread to keep up with the application.

Freeform:

  • Added better error handling for "unexpected" errors in the FCFL.NET Platform Adapter for Dovetail Email Agent when in 'freeform' mode. Serious database errors were getting caught, but sent only to the Failure Notify email box, not to the Admin General Error Alert email box in all circumstances. While it might be impossible to handle every type of error scenario, the vast majority of them will now be caught and an Admin General Error Alert email will go out when there are serious problems processing freeform emails.
  • When logging notes to a subcase with an attachment, an error would occur during the creation of the activity log entry for the attachment. The notes would get logged and the attachment would get saved, but the activity log entry for the attachment would fail.

EEO Redirect:

  • When creating the new outbound message from the original incoming message, Dovetail Email Agent was only adding a linefeed character ('\n', 0x0A) instead of a carriage-return/linefeed combo ('\r\n', 0x0D0A). Certain older email clients require CRLF at the end of every line and can't display individual LF's properly.
  • The X.400 address prefix configuration parameter (default: '/o') is now case insensitive.
  • Added checks for "missing" recipients: Recipients specified in the incoming message, but which are not among the SMTP server's Accepted and Refused recipients. These are special-case recipients (such as malformed X.400 or RFC822 addresses) and should not occur during normal use. When one or more of these "missing" recipients are found, an error will be logged to the log file and an Admin General Error Alert will be emailed out to the admin.
  • When all recipients are either rejected or "missing", a special warning will appear on the "Bad Address Reply" email template letting the user know that the email probably did not hit any of the intended recipients.

Version 1.0.4

New Features:
Freeform:

  • When looking for an existing contact during a 'New Case' email scenario, if there are multiple contacts with the same email address, the first ACTIVE one will be picked, otherwise the first INACTIVE one will be selected. The rules for 'allowInactiveContact' are still in effect and will be applied after the contact is selected.

Fixes:
General:

  • The HTML tag stripping utility wasn't handling HTML with a missing <BODY> tag properly.
  • Handling of attachments is now more robust and accounts for some problems caused by non-compliant attachments sent from some email clients.

Freeform:

  • When looking for an existing contact, OBSOLETE contacts will no longer be selected.
  • Creating a case for a contact with a long email address would fail due to string truncation.

Version 1.0.3

New Features:

General:

  • Added Send/Receive Timeout and Send/Receive Buffer Size config parameters for both SMTP and POP3 connections. See the Configuration Guide for more information.

Fixes:

General:

  • POP3 connection logs were not getting written in all circumstances (usually in error conditions).

Version 1.0.2

New Features:
General:

  • All success and failure notification emails will have the original message attached, as well as forwarded as the message body.
  • eeoredirect mode's "Invalid Recipient" reply email (eeorsbadaddressreply.xslt) now includes the reason why a recipient was rejected.

Freeform:

  • Added a switch to configure whether or not inactive contacts (or contacts at inactive sites) can create cases, log notes, etc. (default is to not allow inactive contacts).
  • Added a switch to determine whether a case should be re-opened before notes are logged (default is leave it closed).
  • Added a way to supply custom field defaults when creating cases and logging notes to cases and subcases. Please see the Dovetail Email Agent Configuration section for information on how to configure this feature.

Fixes:
General:

  • Dovetail Email Agent was not properly checking for recipients refused by the SMTP server when sending any email. These are now being checked and will be reported appropriately for the mode in which Dovetail Email Agent is operating. For example, in eeoredirect mode, invalid recipients will be recorded and noted in a special email to the original sender. If a failure/success notification email fails, it is logged to the log file and the event log and a non-fatal admin general error is sent to the admin. If an email cannot be sent to the admin, then the problem is logged to the log file and the event log.

EEO Redirect Mode:

  • When EEO sent messages through Outlook, Outlook would wrap lines at 72 characters and would cause extra spaces to be lost in certain circumstances. EEO will now hard-wrap lines at 60 characters and suffix them with a special delimeter. 'eeoredirect' mode will now check for these delimeters and handle long email strings properly.

Version 1.0.1

Merged with EEO Redirect Service
The EEO Redirect Service (EEORS) product has been moved into the Dovetail Email Agent email processing engine core. It is now another parsing mode like 'apiinvoke' or 'freeform'. However, EEORS requires a separate license from Dovetail Email Agent. If you intend on using EEORS functionality. Likewise, if you only have an EEORS license, you must have an Dovetail Email Agent license to use the other Dovetail Email Agent functionality (apiinvoke, freeform). Please contact Dovetail Software to obtain any necessary licenses.

Fixes:
General:

  • Certain types of POP3 connection failures were not getting handled by the POP3 connection retry functionality. Instead of retrying the configured number of times, Dovetail Email Agent would stop immediately. These special cases are now being trapped and handled the correct way.
  • If Dovetail Email Agent is accidentally configured to send admin messages to its own POP3 account, an endless loop situation would occur. This would cause many emails to be sent and received in a small period of time, crashing Dovetail Email Agent, the email server, or both (or worse). Dovetail Email Agent now has an option (enabled by default) to check for this loop condition. If this causes problems, it can be disabled by setting the 'sec.check-for-loop' parameter to 'False' in the EmailAgentService.exe.config file.

Freeform Mode:

  • Long email addresses were getting truncated when creating a new contact. On subsequent emails, Dovetail Email Agent was unable to find the contact and would attempt to create the contact again which would fail.

API Invoke Mode:

  • The HELP (TAG) reply email now includes a simple example of how to call that tag/API.
  • The API invoke parser required the ':' to follow immediately after a subtag. The parser is now less rigid and allows for whitespace between the subtag and colon.

Version 1.0.1

Initial Full Release

New Features:

  • API Invoke functionality now fully works
  • Delivery Status Notifications (non-delivery reports, etc) are forwarded to the administrator and Dovetail Email Agent will not attempt to process them as API invoke or freeform.
  • Upgraded to support FCFL.NET 1.2.

Fixes:

  • Event log and log file admin general error dumps had a timestamp as Zulu/UTC time. They now still display the local time, but with the UTC delta at the end (i.e. -6:00)
  • Dovetail Email Agent Service or Console process will now terminate when the daemon thread ends.
  • In certain circumstances, failure notification emails were not being sent.
  • When saving attachments with attachUseSubFolders = false, Dovetail Email Agent required a number scheme called "SEC_Attach" to be present in the database. Dovetail Email Agent now generates its own unique filenames without using number schemes.
  • Minor documentation corrections
  • The License Installer that shipped with 0.9 had missing dependencies
  • "RE:" was being prepended to every reply message, even if there was already a "RE:"
  • HTML-only emails were not getting processed. Dovetail Email Agent will now strip HTML formatting from HTML-only emails. Note: this is not a 100% solution as HTML formatting is generally not reliable. Most emails will look fine, but if the HTML is malformed, data could be lost.
  • Duplicate tag names in the tag XML will no longer cause Dovetail Email Agent to fail to start. A warning will be logged to the event log and the log file (if logging is enabled).
  • Directories with invalid culture names in the Templates folder will no longer cause Dovetail Email Agent to fail to start. A warning will be logged to the Event Log and the log file (if logging is enabled).
  • Added more delimiters to the delimiters.dat file to support more email clients.

Version Beta 1 (0.9)

Initial Release

NOTE: API Invoke functionality does not work or will produce erratic behavior in this release. Please do not attempt to use API invoke functionality. Dovetail Software will not support this functionality in this release. Working API invoke functionality is planned for the next release.

What’s New

Did this topic help you? Email us your feedback.
Last updated: 10/1/2007 4:05:51 PM


Installation Guide

NOTES BEFORE INSTALLING:

  • To install a second or subsequent instance of the Dovetail Email Agent service on the same computer, please read the Running Multiple Dovetail Email Agent Services section instead of this guide.
  • Before installing SEC .NET, please read the System Requirements and Security Considerations sections.

In This Chapter

Requirements

Packaging

Installing Dovetail Email Agent

License Installation

Configuring Dovetail Email Agent

Running Multiple Dovetail Email Agent Services

What Now?

Security Considerations

Next

Requirements
Installation Guide

Did this topic help you? Email us your feedback.
Last updated: 10/18/2007 3:27:44 PM


Requirements

This version of Dovetail Email Agent requires the following:

Operating System
  • Microsoft™ Windows™ 2000 Professional and Server Family (all 32-bit versions),
  • Microsoft™ Windows™ XP Professional (all 32-bit versions)
    - OR -
    Microsoft™ Windows™ Server 2003 Family (all 32-bit versions).

NOTE: Dovetail Email Agent and the Dovetail SDK may run in a 64-bit environment in 32-bit emulation mode. This configuration has not been tested and is not officially supported by Dovetail Software.

Microsoft Data Access Components 2.8 or later
  • Download from: http://msdn2.microsoft.com/en-us/data/default.aspx

Microsoft™ .NET Framework 2.0 Runtime
  • Install through Windows Update
    -OR-
    Download from: http://msdn2.microsoft.com/en-us/netframework/default.aspx

Hardware
  • Intel™ Pentium II (or compatible) 400MHz or faster
  • 256 MB RAM (512MB recommended) or higher
  • 20MB (estimate) free hard disk space or more

Clarify™ System Environment
  • Clarify™ 7.0 through 12.5
  • Microsoft™ SQL Server™ 2000 SP3 or later
    - OR -
    Oracle™ Database Server 7.2.3 or later

See Also

Installation Guide

Packaging

Installing Dovetail Email Agent

License Installation

Configuring Dovetail Email Agent

Running Multiple Dovetail Email Agent Services

What Now?

Security Considerations

Next

Packaging
Requirements

Did this topic help you? Email us your feedback.
Last updated: 2/4/2009 10:53:43 AM


Packaging

Dovetail Email Agent is shipped as a ZIP file containing the MSI installation package and this user guide.

See Also

Installation Guide

Requirements

Installing Dovetail Email Agent

License Installation

Configuring Dovetail Email Agent

Running Multiple Dovetail Email Agent Services

What Now?

Security Considerations

Next

Installing Dovetail Email Agent
Packaging

Did this topic help you? Email us your feedback.
Last updated: 10/2/2007 2:06:32 PM


Installing Dovetail Email Agent

Run the installation process by double-clicking the MSI file.

The installation will then proceed through a series of steps or screens which will either provide information about the installation process, or request information necessary to install Dovetail Email Agent.

See Also

Installation Guide

Requirements

Packaging

License Installation

Configuring Dovetail Email Agent

Running Multiple Dovetail Email Agent Services

What Now?

Security Considerations

Next

License Installation
Installing Dovetail Email Agent

Did this topic help you? Email us your feedback.
Last updated: 10/18/2007 3:28:59 PM


License Installation

You should have received a license for Dovetail Email Agent either with your distribution or separately. If you have not received a license for Dovetail Email Agent, please contact us to obtain one.

To install your Dovetail Email Agent license:

  1. Execute the Dovetail Software License Installer which is found in the Dovetail Email Agent installation root.
  2. The database connection/login screen will appear (Figure 2). This allows License Installer to connect to your Clarify™ database instance and view current and install new Dovetail Software licenses. Please enter required information (all fields are required except for "DB Name" when the database type is "Oracle") and click "Login". The License Installer will then attempt to connect to the database.

    Figure 2: License Installer Login Screen

  3. After successfully connecting to the database and retrieving any existing license information, the license information screen (Figure 3) will be displayed. This will list any existing licenses and some basic information about them. It also allows you to install new licenses by clicking on the "Install New License(s)" button.

    Figure 3: License Installer License Information Screen

  4. To install a new license or licenses, click the "Install New License(s)" button. You will be prompted (see Figure 4) to select an XML license file, or paste a license XML fragmant you may have received in an email or other source. Once you have loaded or pasted the XML fragment, click the "Install" button to install the license.

    Figure 4: License Installer Load License Screen

  5. If the installation is successful, the license information screen will appear. The newly installed license(s) should appear in the list of installed license. At this point the License Installer can be closed, or new licenses can be installed as many times as is needed. If the installation is not successful, an error dialog window will appear giving further details about what went wrong.

See Also

Installation Guide

Requirements

Packaging

Installing Dovetail Email Agent

Configuring Dovetail Email Agent

Running Multiple Dovetail Email Agent Services

What Now?

Security Considerations

Next

Configuring Dovetail Email Agent
License Installation

Did this topic help you? Email us your feedback.
Last updated: 10/2/2007 2:07:24 PM


Configuring Dovetail Email Agent

Once the MSI installation package has completed, you must edit two configuration files.

  • The configuration file for the Windows Service is named EmailAgentService.exe.config and is located in the installation directory (typically C:\Program Files\Dovetail Software\Email Agent). Review the Service Configuration guide for more details.
  • The configuration file for Dovetail Email Agent's operation is named email-agent-config.xml and is located in the installation directory (typically C:\Program Files\Dovetail Software\Email Agent). Review the Dovetail Email Agent Configuration Guide for more details.

See Also

Installation Guide

Requirements

Packaging

Installing Dovetail Email Agent

License Installation

Running Multiple Dovetail Email Agent Services

What Now?

Security Considerations

Next

Running Multiple Dovetail Email Agent Services
Configuring Dovetail Email Agent

Did this topic help you? Email us your feedback.
Last updated: 10/4/2007 3:10:53 PM


Running Multiple Dovetail Email Agent Services

A single Dovetail Email Agent service can poll for incoming email on one email box. It is common that multiple mailboxes need to be polled. For example: Poll the "support@company.com" mailbox, and process as freeform text. Poll the "clearsupport_interface@company.com" mailbox, and process using API Invoke mode.

The first service is installed by default when running the Dovetail Email Agent Setup program. Follow the steps below to run multiple Dovetail Email Agent services on the same server.

Warning: When one instance of the Dovetail Email Agent service sends an email to another instance of the Dovetail Email Agent service (running on the same machine or a different one), it can create an email loop where the two instances of Dovetail Email Agent will bounce responses back and forth forever. This can cause serious performance problems. To prevent this from occurring, each instance of the Dovetail Email Agent service has a unique identifier. When installing additional Dovetail Email Agent instances, you must set this identifier manually with the secServiceUniqueIdentifer parameter. For more information about the secServiceUniqueIdentifer parameter, go to the Dovetail Email Agent Configuration Parameters Reference section.

To setup a 2nd service on the same server

  1. Create a new working directory for the 2nd service.
  2. Copy all the files from the first installation directory into the new working directory.
    For example, copy all of the files from C:\Program Files\Dovetail Software\Email Agent to C:\Program Files\Dovetail Software\EmailAgent2
  3. Run the email-agent-setup.bat script. This needs to be run from a DOS command prompt.

    Usage:

    email-agent-setup [/u] [/v] "servicedisplay" "servicename" "serviceemail" "emailhost" "pop3user"

    "pop3pass" "fromemail" "attachmentpath" "parsemode"

    NOTES:

    • Switches /u and /v are not required
    • When not using /u (uninstall), all parameters are required

    Please put double-quotes (") around parameters as shown in the example above

    Switch

    Description

    /u

    Uninstall Dovetail Email Agent in this folder (all further parameters and switches are not required)

    /v

    Enable verbose log output of install/uninstall

    Parameter

    Description

    servicedisplay

    The display name of the server (appears in the Services applet, may contain spaces)

    servicename

    The internal name of the service (must not contain spaces)

    serviceemail

    The email address which will receive administrative notifications from Dovetail Email Agent

    emailhost

    Email server (POP3 and SMTP) hostname or IP

    pop3user

    POP3 mailbox username

    pop3pass

    POP3 mailbox password

    fromemail

    The email to use as the FROM address when sending out emails to customers. Use the format: "Display Name <email@address.com>"

    attachmentpath

    The local or UNC path to use for storing incoming email attachments
    IMPORTANT: Do not put trailing slashes on the path.

    parsemode

    1 = Freeform, 2 = API Invoke, 3 = EEO Redirect

    For example:

    email-agent-setup "emailagent2" "emailagent2" "clearsupport_interface@company.com", "my_mail_server", "login","password", "outgoing_from_address@company.com", "c:\attachments","2"

  4. After the main install is complete, you will be prompted by the ConfigEditor to edit the database connection string. If this new service is going to use the same database instance as original service, click 'No'. Otherwise, click 'Yes' and edit the database parameters as necessary.
  5. Once the install is complete, if you wish to set any of the additional configuration parameters, edit the Dovetail Email Agent configuration file (email-agent-config.xml).
  6. Start the service.

See Also

Installation Guide

Requirements

Packaging

Installing Dovetail Email Agent

License Installation

Configuring Dovetail Email Agent

What Now?

Security Considerations

Next

What Now?
Running Multiple Dovetail Email Agent Services

Did this topic help you? Email us your feedback.
Last updated: 10/18/2007 3:34:48 PM


What Now?

  • Read about special considerations
    There are two major special considerations before starting the Dovetail Email Agent service:
    • Security Concerns
      For more information, read the Security Considerations section.
    • Custom Case ID number schemes
      If you have a custom case ID number scheme, read the Numbering Schemes section.
  • Start the service
    By default, after the service is installed, it is not started. In order for Dovetail Email Agent to begin processing emails, the service must be started. Open Control Panel, Administrative Tools, and open the 'Services' applet. Find the SecService service in the list (or whatever name you gave your service during installation), and then click the "Play" or "Start" button in the toolbar. Dovetail Email Agent should start after a few seconds. If it fails to start, you will be prompted with a generic error messages from Windows. Consult the Windows Event Viewer to get more information about why Dovetail Email Agent failed to start. To run the Event Viewer, open the "Event Viewer" applet in the same folder where the "Services" applet was.

See Also

Installation Guide

Requirements

Packaging

Installing Dovetail Email Agent

License Installation

Configuring Dovetail Email Agent

Running Multiple Dovetail Email Agent Services

Security Considerations

Next

Security Considerations
What Now?

Did this topic help you? Email us your feedback.
Last updated: 10/2/2007 2:08:02 PM


Security Considerations

The Dovetail Email Agent installer defaults the Dovetail Email Agent service to run under the operating systems predefined local service account. For example, this account is named "NetworkService" on Windows Server 2003. Some Dovetail Email Agent features may require more privileges than this account provides. For improved security, you may want to create a new account and grant the necessary permissions to that account.

This account should have the following privileges:

  • Read and execute access to the Dovetail Email Agent install directory (typically C:\Program Files\Dovetail Software\Email Agent)
  • If saving attachments to a network share, permissions to access the network and read/write access to the attachments directory.
  • If logging or enabling EmailTracking, read/write write permissions to the folder where the log files will be created as well as to a folder configured to receive the EmailTracking emails.
  • Any other permissions to folders or files used by the software. For example:
    • Read/Execute access to the .NET Framework Runtime assemblies
    • For Oracle users, read/execute access to the Oracle client bin folder

See Also

Installation Guide

Requirements

Packaging

Installing Dovetail Email Agent

License Installation

Configuring Dovetail Email Agent

Running Multiple Dovetail Email Agent Services

What Now?

Next

Configuration
Security Considerations

Did this topic help you? Email us your feedback.
Last updated: 10/4/2007 3:01:48 PM


Configuration

In This Chapter

Service Configuration

Dovetail Email Agent Configuration

Logging Configuration

API Tags and Subtags Configuration

Next

Service Configuration
Configuration

Did this topic help you? Email us your feedback.
Last updated: 8/16/2007 3:26:24 PM


Service Configuration

See Also

Configuration

Dovetail Email Agent Configuration

Logging Configuration

API Tags and Subtags Configuration

Next

Configuration Parameters Introduction
Service Configuration

Did this topic help you? Email us your feedback.
Last updated: 10/1/2007 2:38:30 PM


Configuration Parameters Introduction

Configuration parameters for the Dovetail Email Agent Service are specified in the EmailAgentService.exe.config found in the Dovetail Email Agent install directory.

After entering all the required parameters a EmailAgentService.exe.config files could look similar to the following:

<?xml version="1.0" encoding="utf-8" ?>
<configuration>
  <appSettings>
    <add key="sec.servicename" value="SecService" />
    <add key="sec.workingDir" value="C:\Program Files\Dovetail Software\Email Agent\" />
    <add key="sec.service-address" value="support@company.com" />
    <add key="sec.admin-address" value="admin@company.com" />
    <add key="sec.check-for-loop" value="True"/>
    <add key="sec.finalizer-wait-freq" value="0"/>
    <add key="fchoice.disableLoginFromFCApp" value="false"/>
    <add key="fchoice.dbtype" value="MSSQL" />
    <add key="fchoice.connectionstring" value="Data Source=server_name; Initial Catalog=database_name; User Id=emailclerk; Password=emailclerk_password;" />
    <add key="fchoice.logconfigfile" value="C:\Program Files\Dovetail Software\Email Agent\email-agent.log.config" />
  </appSettings>
</configuration>

See Also

Service Configuration

Service Configuration Parameters Reference

Next

Service Configuration Parameters Reference
Configuration Parameters Introduction

Did this topic help you? Email us your feedback.
Last updated: 10/9/2007 2:27:09 PM


Service Configuration Parameters Reference

Parameter Name | Description
sec.servicename | This is the Dovetail Email Agent Win32 Service short name (the one without spaces). This *MUST* match EXACTLY to the name you typed in during the Dovetail Email Agent install
sec.workingDir | This is the path that Dovetail Email Agent will use to find it's dependency DLLs, configuration, store cache information, and find the delimiters.dat file.
sec.service-address | This is the FROM: addres to use when fatal or severe errors occur and Dovetail Email Agent needs to send an email to the administrator
sec.admin-address | This is the TO: address to use when sending out fatal or severe errors that may occur during Dovetail Email Agent operation
sec.check-for-loop | Specifies whether Dovetail Email Agent should detect whether or not it is sending emails to itself (which could cause very rapid email generation and could crash Dovetail Email Agent or the email server). NOTE: It is strongly recommended you leave this enabled (set to 'true') at all times.
sec.finalizer-wait-freq | Specifies the number of POP3 polls that should occur before Dovetail Email Agent pauses to allow the .NET Garbage Collector and finalizer thread to catch up and process deallocated memory. This is generally only necessary when the POP3 poll frequency is set very high (less than 10 seconds or so) or the system on which Dovetail Email Agent is running is heavily taxed and frequently has high CPU and memory utilization. Setting this value to 0 or less disables this functionality.
fchoice.disableLoginFromFCApp | By default, the Dovetail SDK will not allow the username and password specified in the fchoice.connectionstring configuration value to be used as the Clarify™ session login. In many circumstances, doing so would be a security risk. However, for back-office services, such as Dovetail Email Agent, this is not a security risk and is acceptable usage. Setting this value to 'true' allows the Dovetail SDK to use the username and password specified in the fchoice.connectionstring configuration value as the Clarify™ session username and password. NOTE: This value should ALWAYS be 'false'. Please do not tamper with it as Dovetail Email Agent might be unable to connect to your database properly.
fchoice.dbtype | Clarify database engine type (MSSQL, ORACLE, etc)
fchoice.connectionstring | Database connection string. Please use the ConfigEditor included in the Dovetail Email Agent install root to edit this value
fchoice.logconfigfile | Path to log4net configuration file

See Also

Service Configuration

Configuration Parameters Introduction

Next

Dovetail Email Agent Configuration
Service Configuration Parameters Reference

Did this topic help you? Email us your feedback.
Last updated: 10/9/2007 2:28:43 PM


Dovetail Email Agent Configuration

See Also

Configuration

Service Configuration

Logging Configuration

API Tags and Subtags Configuration

Next

Configuration Parameters Introduction
Dovetail Email Agent Configuration

Did this topic help you? Email us your feedback.
Last updated: 10/2/2007 2:09:02 PM


Configuration Parameters Introduction

Configuration parameters for Dovetail Email Agent are specified in the email-agent-config.xml found in the Dovetail Email Agent install directory.

After entering all the required parameters one of the simplest email-agent-config.xml files could look like the following:

<?xml version="1.0" encoding="utf-8" ?>
<secConfig>
    <daemonConfig activeConfigGroup="configGroup1" />
    <configGroups>
        <configGroup name="configGroup1">
          <param name="pop3Host" value="popserver" />
          <param name="pop3User" value="popusername" />
          <param name="pop3Pass" value="poppassword" />
          <param name="smtpHost" value="smtphost" />
          <param name="attachPath" value="c:\attachments" />
          <param name="fromAddress" value="user@mydomain.com" />
          <param name="parseMode" value="freeform" />
          <param name="failNotifyEmail" value="admin@mydomain.com" />
          <param name="freeFormNoteFormat" value="About\s+case\s+" />
          <param name="freeFormReplySubjectSuffix" value=" - About case" />

          <caseCreateExtraFields>
            <fieldValue name="x_date" type="date" value="1/1/2005"/>
            <fieldValue name="x_test" type="string" value="testtestest"/>
            <fieldValue name="x_test" type="string">
                <![CDATA[ This is some <b>formatted</b> with HTML and/or "XML" text in it. ]]>
            </fieldValue>
          </caseCreateExtraFields>

          <logCaseNoteExtraFields>
                    <fieldValue name="x_test" type="string" value="testtestest"/>
          </logCaseNoteExtraFields>

          <logSubcaseNoteExtraFields>
                    <fieldValue name="x_test" type="string" value="testtestest"/>
          </logCaseNoteExtraFields>

          <ignoreList>
                    <add address="someone@somewhere.com" action="ignore"/>
                    <add address="another@somewhere.com" action="sendFailNotify"/>
          </ignoreList>

        </configGroup>
    </configGroups>
</secConfig>

Parameters and Whitespace

The email-agent-config.xml configuration file <param> elements can also use the XML element text when a value attribute is not present.

Parameter Value as an attribute:

<param name="setting" value="parameter value"/>

Parameter Value as an element value:

<param name="setting">
    parameter value
</param>
In the example above the white space including line returns will be present in the parameter value

See Also

Dovetail Email Agent Configuration

Dovetail Email Agent Configuration Parameters Reference

caseCreateExtraFields, logCaseEmailInExtraFields, and logSubcaseEmailInExtraFields Schema

ignoreList Schema

Email Tracking

Next

Dovetail Email Agent Configuration Parameters Reference
Configuration Parameters Introduction

Did this topic help you? Email us your feedback.
Last updated: 6/19/2008 4:24:11 PM


Dovetail Email Agent Configuration Parameters Reference

Parameter Name

Required

Default

Description

Pop Parameters

pop3Host

Yes

(blank)

IP or hostname of the POP3 server

pop3User

Yes

(blank)

POP3 mailbox user name

pop3Pass

Yes

(blank)

POP3 mailbox user password

pop3PollInterval

No

30

The number of seconds to wait between attempts to retrieve mail from the POP3 mailbox.

pop3FailureRetryTime

No

600

If there is a problem connecting to the POP3 server, this value controls how long in seconds Dovetail Email Agent will wait before trying again.

pop3FailureRetryCount

No

6

If there is a problem connecting to the POP3 server, this value controls how many consecutive times Dovetail Email Agent will attempt to re-connect before giving up and shutting down.

NOTE: if a valid connection is established, the counter is reset.

pop3Port

No

110

The TCP/IP port to use when connecting to the POP3 server.

pop3ReceiveBufferSize

No

8192

The size of the receive buffer in bytes for the underlying client socket. Default is 8192 bytes.

pop3SendBufferSize

No

128

The size of send buffer in bytes for the underlying client socket. Default is 128 bytes.

pop3ReceiveTimeout

No

60000

The amount of time the underlying TcpClient socket will wait to receive data once initiated. Default is 60,000 milliseconds (1 minute).

pop3SendTimeout

No

10000

The amount of time the underlying Client socket will wait to receive confirmation after you initiate a send. Default is 10,000 milliseconds (10 seconds).

pop3AuthType

No

UserPass

Specifies the type of POP3 authentication Dovetail Email Agent should use when logging into the POP3 server. Valid values are: APOP, CRAM_MD5, Digest_MD5, GSSAPI, Login, None, NTLM, UserPass, UseStrongest

pop3SecurityType

No

None

Specifies the type of transport security Dovetail Email Agent should use when connecting to the POP3 server. Valid values are: None, SslSocket, TransportLayer

SMTP Parameters

smtpHost

Yes

(blank)

IP or hostname of the SMTP server

fromAddress

Yes

(blank)

The email address that Dovetail Email Agent should use in the FROM: field when sending out emails

This can be in the format:
Display Name <email@address.com> or simply:
email@address.com

Take care to escape any < and > characters with the XML escape sequences &lt; and &gt; respectively

smtpPort

No

25

The TCP/IP port to use when connecting to the SMTP server.

smtpReceiveBufferSize

No

128

The size of the receive buffer in bytes for the internal communication socket. Default is 128 bytes.

smtpSendBufferSize

No

4096

The size of send buffer in bytes for the internal communication socket. Default is 4096 bytes.

smtpReceiveTimeout

No

60000

The amount of time the underlying TcpClient socket will wait to receive data once initiated. Default is 60,000 milliseconds (1 minute).

smtpSendTimeout

No

10000

The amount of time the underlying Client socket will wait to receive confirmation after you initiate a send. Default is 10,000 milliseconds (10 seconds).

smtpUser

No

(blank)

The username to use when connecting to the SMTP server. Some SMTP Servers require authentication.

smtpPass

No

(blank)

The password to use when connecting to the SMTP server. Some SMTP Servers require authentication.

smtpAuthType

No

None

Specifies the type of SMTP authentication Dovetail Email Agent should use when connecting to the SMTP server. Valid values are: CRAM_MD5, Digest_MD5, GSSAPI, Login, None, NTLM, UseStrongest

smtpSecurityType

No

None

Specifies the type of transport security Dovetail Email Agent should use when connecting to the SMTP server. Valid values are: None, SslSocket, TransportLayer

Application Parameters

parseMode

Yes

(blank)

Parsing mode: apiinvoke, freeform, or eeoredirect (NOTE: 'eeoredirect' mode requires a separate license)

attachPath

Yes

(blank)

Local or UNC path in which to store email attachments.

failNotifyEmail

No

(same as service admin email address)

The address which will receive failure notifications (blank for none)

successNotifyEmail

No

blank for none

The address which will receive success notifications (blank for none)

useHtmlEmailFormat

No

true

Controls which type of emails Dovetail Email Agent sends out to users. Valid values are "false" for plaintext, non-formatted emails or "true" for HTML formatted emails.

NOTE: If you're switching from HTML to plaintext, you must reformat your XSLT templates accordingly, otherwise users will see the raw HTML tags. Going from plaintext to HTML will not be a problem as the users will be sent the plaintext as normal.

attachFolderMode

No

ModeA

Specifies which sub-folder mode Dovetail Email Agent should use when saving attachments.

NOTE: The value is NOT case-sensitive (i.e. 'modea' works as well as 'MODEA').

Valid values are:

  • ModeA: Put all files directly into the path specified by attachPath.

ModeB: Put attachments in subfolders using the CASE ID as a folder prefix.

For example, if the attachPath is set to "c:\attachments", attachments from Case 1792 will be stored in the path:

C:\attachments\001xxx\001792\

This mode groups up to a 1,000 cases in a grouping folder to help organize the attachments.

ModeC: Similar to ModeB but the folder names are slightly different.

For example, if the attachPath is set to "c:\attachments", attachments from Case 1792 will be stored in the path:

C:\attachments\1700\1792\

This mode groups up to 100 cases in a group folder to help organize the attachments.

defaultLocale

No

en-US

This controls what template will be used to send emails to users when their locale is unknown (can't be found in Clarify or discovered from their email).

NOTE: Dovetail Email Agent does not currently check contacts or emails for locale information, it only uses the defaultLocale. Future versions may support multiple locales, in which case this setting takes on new meaning.

helpEnabled

No

true

Specifies whether the Dovetail Email Agent help system is enabled for API invoke mode. If someone requests help or submits an invalid request, should help messages be sent in reply.

createContact

No

true

Should Dovetail Email Agent create a contact in the Clarify system if one cannot be found with the given email address from a freeform email.

If set to true, a new contact will be created whose first name, last name, phone number, and email address will all be set to the from address of the incoming email. The contact role will be set to the default, and it will be related to the site whose site_id is defined in the newContactDefaultSite parameter.

newContactDefaultSite

Required if createContact=true

INT1

If createContact is enabled, this tells Dovetail Email Agent the site id to relate the new contact to.

allowInactiveContact

No

false

(Only applies to freeform mode) Determines whether Dovetail Email Agent will allow emails from an inactive contact to be processed. If false, the user gets a generic error email and an email is sent to the failure notification address. If true, the contact is treated like normal.

reopenCaseToLogEmailIn

No

false

(Only applies to freeform mode) Determines whether Dovetail Email Agent will re-open a closed case (or subcase) before logging notes to it. If false, notes are logged to the closed case.

sendSuccessReply

No

true

Should Dovetail Email Agent send an affirmative reply to a user after it completes the requested action. Occurs in both in freeform and in API invoke modes.

NOTE: This value trumps the sendLogEmailInInSuccessReply parameter.

sendLogEmailInSuccessReply

No

true

Should Dovetail Email Agent send an affirmative reply to a user after it successfully logs notes to a case/subcase from an incoming email. This value applies only to freeform mode.

NOTE: sendSuccessReply trumps this value. If sendSuccessReply is false, then this value is ignored.

sendFailureReply

No

true

Should Dovetail Email Agent send a failure reply after it encounters an error performing the requested action. Occurs in both in freeform and in API invoke modes.

sendParseErrorReply

No

true

Should Dovetail Email Agent send an error reply to a user after it encounters an error parsing an email request. Occurs in both in freeform and in API invoke modes.

numberDashesInCaseId

No

0

If the case ID number scheme contains dashes, this tells Dovetail Email Agent how many dashes it contains so it can process subcases correctly.
More information on this topic is available in the Special Case ID Numbering Schemes section.

freeFormNoteFormat

Required if parsemode=freeform

About\s+case\s+

The message format Dovetail Email Agent will look for when in freeform parse mode. It will look for "About case xxxx " where "About case " is your freeFormNoteFormat and xxxx is the case ID. The format of this string can contain .NET Regular Expression tokens. For more information, see the .NET Framework SDK documentation on Regular Expressions

freeFormNoteFormatLocation

No

subject

Determines where Dovetail Email Agent will look for the freeFormNoteFormat when in freeform parse mode. Valid values are subject, body, or both.

freeFormReplySubjectSuffix

Required if parsemode=freeform

- About case

When in freeform mode, and replying to a freeform note that has caused a case to be created, Dovetail Email Agent will append this text to the original subject. This is useful when the user replies to an email as it will preserve the workflow of case notes. This text will be appended immediately after the subject and followed by a space and then the actual case ID.

freeFormTextAfterID

No

true

This tells Dovetail Email Agent whether or not there will be additional text after the case ID.

If you have spaces in your ID number scheme, this MUST be set to false. Additional text is NOT allowed after the CASE ID if your case number format has spaces.
More information on this topic is available in the Special Case ID Numbering Schemes section.

removeOriginalMessage

No

true

When processing free-form emails, sometimes the emails are replies or forwards and contain the original message that's being forwarded or replied-to. This controls whether or not Dovetail Email Agent will remove the original message, or leave it.

Dovetail Email Agent will used the delimiters defined in the delimeters.dat file to determine the start of the original message.

useEmailTimeForCaseCreate

No

false

This controls what time Dovetail Email Agent should specify for the case creation time when processing freeform emails. By default, it uses the current date and time on the database server, but it can, instead, use the time the user sent their email.

extraNoteInfo

No

true

This tells Dovetail Email Agent whether or not to prepend "extra note info" when logging case notes to a case in freeform mode. "Extra note info" consists of a typical email-type header with the FROM:, the TO:, the subject, the time the email was sent, etc

sessionLocalTimezone

No

(blank)

The full name of the TimeZone you wish the Dovetail Email Agent ClarifySession to run as. It is important to set this value when Dovetail Email Agent and the Clarify Database are located in different timezones. The default value will be the LocalCache's DefaultTimeZone.

freeFormContactValidatorType

No

(blank)

Specifies the fully-qualified .NET name of a type that will perform custom contact validation. See the Custom Contact Validation topic for more details.

allowFreeformCaseCreate

Yes

true

(Only applies to freeform mode) Should Dovetail Email Agent allow case creation.

If this value is set to "false", and an incoming email attempts to create a new case, then the sender will receive a reply using the FreeformWontCreateCase.xslt template.

allowFreeformLogEmailIn

Yes

true

(Only applies to freeform mode) Should Dovetail Email Agent allow notes to be logged to a case/subcase.

If this value is set to "false", and an incoming email attempts to log notes to an existing case or subcase, then the sender will receive a reply using the FreeformWontLogNote.xslt template.

allowLogEmailInToClosedCases

Yes

true

(Only applies to freeform mode) Should Dovetail Email Agent allow notes to be logged to a closed case.

If this value is set to "false", and an incoming email attempts to log notes to a closed case, then the sender will receive a reply using the FreeformClosedCaseNotesFailure.xslt template.

allowLogEmailInToClosedSubcases

Yes

true

(Only applies to freeform mode) Should Dovetail Email Agent allow notes to be logged to a closed subcase.

If this value is set to "false", and an incoming email attempts to log notes to a closed subcase, then the sender will receive a reply using the FreeformClosedCaseNotesFailure.xslt template.

processDSNMessages

Yes

false

Should Dovetail Email Agent process DSN (Delivery Status Notification) messages.

Examples of DSN Messages:

  • The recipient address is misspelled or doesn't exist
  • Full disk or full mailbox
  • Rejection of the message due to spam filtering, etc.
  • Delay in delivering the message
  • etc.

If this value is set to "false", and an incoming DSN email is received, then the email will be forwarded to the Dovetail Email Agent admin.

If this value is set to "true", and an incoming DSN email is received, then the email will be processed as a normal email.

sendReplyToDSNMessages

Yes

false

Should Dovetail Email Agent send a reply to DSN (Delivery Status Notification) messages.

It is recommended that this value be left to "false" to prevent an infinite email loop.

Application Settings

enableEmailTracking

No

false

This tells Dovetail Email Agent to save all incoming and outgoing emails to files in a specified folder (see the emailTrackingPath param). This should only be enabled for debugging purposes or for high-security/auditing situations.
More information on this topic is available in the Email Tracking section.

saveWholeEmailAsDovetailAttachment.Enabled

No

false

When in freeform mode this tells Dovetail Email Agent to attach the entire email as an attachment to the case or subcase being processed.

This feature is useful for preserving the original email with its formatting, images, and embedded attachments.

saveWholeEmailAsDovetailAttachment.FileExtension

No

mht

When saveWholeEmailAsDovetailAttachment is enabled this setting controls the file extension used when saving the email as an attachment to case or subcase being processed.

The default mht (mime html) extension can be viewed using Internet Explorer. An alternative is eml which can be viewed using Outlook Express.

saveWholeEmailAsDovetailAttachment.HistoryAppenderTemplate

No

When this setting is empty it has no effect.

When saveWholeEmailAsDovetailAttachment is enabled. This value when populated will be appended to the case or subcase history.

The template can contain tokens:

  • {caseId}
  • {attachmentFileName}
  • {attachmentDirectory}
  • {attachmentSubDirectory}

An example would be if you wished to append a hyperlink pointing to an attachment service:

http://server/attachments/{attachmentSubDirectory}\{attachmentFileName}

This example will resolve to:

http://server/attachments/00\59\IncomingEmail-20080619-143737990.mht

emailTrackingPath

No

EmailTracking

This tells Dovetail Email Agent where to save all incoming and outgoing emails when enableEmailTracking is set to True (see enableEmailTracking). This must be a full path (no relative paths) or a path that is relative from the Dovetail Email Agent working dir (see the EmailAgentService.exe.config file). Proper permissions must be set for the Dovetail Email Agent service user ('NETWORK SERVICE' by default on Windows XP and 2003 Server) to write to this folder.
More information on this topic is available in the Email Tracking section.

secServiceUniqueIdentifer

Yes

Dovetail-SEC-Service-Instance-001

A unique identifier for the SEC Instance. This value is added to email headers to assist in detecting email loops that can occur when two instances of Dovetail Email Agent send email to each other.

See Also

Dovetail Email Agent Configuration

Configuration Parameters Introduction

caseCreateExtraFields, logCaseEmailInExtraFields, and logSubcaseEmailInExtraFields Schema

ignoreList Schema

Email Tracking

Next

caseCreateExtraFields, logCaseEmailInExtraFields, and logSubcaseEmailInExtraFields Schema
Dovetail Email Agent Configuration Parameters Reference

Did this topic help you? Email us your feedback.
Last updated: 9/19/2008 4:05:57 PM


caseCreateExtraFields, logCaseEmailInExtraFields, and logSubcaseEmailInExtraFields Schema

This section of the Dovetail Email Agent XML configuration file applies only when parseMode is set to 'freeform'.

When Dovetail Email Agent creates or logs notes to a case, you can have Dovetail Email Agent set additional/custom fields on the case. This section of the XML file allows you to specify the names, types, and values to use for these fields. The XML consists of a three optional tags ('<caseCreateExtraFields>', '<logCaseEmailInExtraFields>', and '<logSubcaseEmailInExtraFields>') which may contain one or more instances of subtag '<fieldValue>'. The '<fieldValue>' schema is outlined below.

WARNING: All tag and attribute names are CASE SENSITIVE.

<fieldValue> Tag

<caseCreateExtraFields>
    <fieldValue name="x_name" type="string" value="George">
    <fieldValue name="x_date" type="date" value="1/1/2005">
    <fieldValue name="x_num" type="long" value="542">
</caseCreateExtraFields>

NOTE: To specify "NOW" for a date field, use the value -999. Example:

<fieldValue name="x_last_mod_date" type="date" value="-999">

NOTE: Instead of the 'value' attribute, you can place the value as the inner text of the tag. This allows you to use a CDATA section for specially formatted text. Example:

<fieldValue name="x_test" type="string">
  <![CDATA[ This is some <b>formatted</b> with HTML and/or "XML" text in it. ]]>
</fieldValue>

Attribute | Required | Default | Description
name | Yes | N/A | Specifies the name of the actual field/column on the table.
type | Yes | N/A | Specifies the type of the data. Valid values are: string long double date
value | no (if inner text is present) | (empty string) | Specifies the value to use for this field. The value must be convertible to the type specified in the 'type' element. Please consult the .NET Framework SDK documentation for DateTimeFormatInfo and NumberFormatInfo for valid formats for 'long', 'double', and 'date' type values. To specify "NOW" for a date type field, use -999.
(inner text) | no (if value attribute is present) | (empty string) | Can be used instead of the value attribute to specify a complicated value. Refer to the value attribute documentation above for the requirements of this text.

See Also

Dovetail Email Agent Configuration

Configuration Parameters Introduction

Dovetail Email Agent Configuration Parameters Reference

ignoreList Schema

Email Tracking

Next

ignoreList Schema
caseCreateExtraFields, logCaseEmailInExtraFields, and logSubcaseEmailInExtraFields Schema

Did this topic help you? Email us your feedback.
Last updated: 9/19/2008 4:08:36 PM


ignoreList Schema

Dovetail Email Agent can be configured to take a specific action when it receives an email from a specific email address. Use the <ignoreList> section in the configuration XML file to configure the list of addresses and the action to take for each address.

WARNING: All tag and attribute names are CASE SENSITIVE.

<add> Tag

<ignoreList>
    <add address="someone@somewhere.com" action="ignore">
    <add address="another@somewhere.com" action="sendFailNotify">
</ignoreList>

Attribute

Required

Default

Description

address

Yes

N/A

Specifies the full RFC822/SMTP email address on which to perform the specified ignore action

action

Yes

N/A

Determines which action Dovetail Email Agent should take when a message from this address arrives.

  • ignore: Completely ignore. An INFO entry will be logged to the log file and that is all that will happen. The message will be discarded completely (not processed further).
  • sendFailNotify: A (FAILURE) email will be sent to the configured failNotifyEmail address, an INFO entry will be logged to the log file, and the message will be discarded completely (not processed further).

See Also

Dovetail Email Agent Configuration

Configuration Parameters Introduction

Dovetail Email Agent Configuration Parameters Reference

caseCreateExtraFields, logCaseEmailInExtraFields, and logSubcaseEmailInExtraFields Schema

Email Tracking

Next

Email Tracking
ignoreList Schema

Did this topic help you? Email us your feedback.
Last updated: 10/9/2007 2:41:11 PM


Email Tracking

Dovetail Email Agent has the capability to store all incoming and outgoing emails as EML files. This feature is typically only used for debugging purposes, or in high-security or auditing scenarios. This feature can be enabled by setting the enableEmailTracking parameter to true in the email-agent-config.xml file. The directory where these files are saved can be defined using the emailTrackingPath parameter. See the Dovetail Email Agent Configuration Parameters Reference for more information on the specifics of these parameters.

Next

Logging Configuration
Email Tracking

Did this topic help you? Email us your feedback.
Last updated: 10/4/2007 3:09:15 PM


Logging Configuration

Dovetail Email Agent uses the same logging framework that is built into the Dovetail SDK. This framework allows developers and administrators a high degree of flexibility to control the quality and detail of the information Dovetail Email Agent generates.

  • Logging capabilities include:
  • Different log levels: Debug, Info, Warning, Error, and Fatal
  • Can log to: File, Database, Windows Event Log, Email, several other sources, or any combination of these
  • Set maximum log file size, number of file rollovers, etc
  • Configurable log output (date/time format, log source, etc)
  • Dynamic configuration: Make changes on-the-fly, without re-starting your application
  • Log all the POP3 and SMTP traffic

Logging Configuration parameters for Dovetail Email Agent are specified in the email-agent.log.config file found in the email-agent.log.config file is an XML Configuration file. The configuration is easily readable and updateable while retaining the flexibility to express all configurations.

For full details on configuring the logging configuration file, please refer to the Logging section in the Dovetail SDK documentation.

See Also

Configuration

Service Configuration

Dovetail Email Agent Configuration

API Tags and Subtags Configuration

Next

API Tags and Subtags Configuration
Logging Configuration

Did this topic help you? Email us your feedback.
Last updated: 10/4/2007 3:15:35 PM


API Tags and Subtags Configuration

See Also

Configuration

Service Configuration

Dovetail Email Agent Configuration

Logging Configuration

Next

API Tags XML
API Tags and Subtags Configuration

Did this topic help you? Email us your feedback.
Last updated: 10/1/2007 4:30:37 PM


API Tags XML

When operating in API Invoke mode, the tags.xml file is used to define how APIs are processed, including:

  • Which APIs are enabled
  • Tag and subtag names
  • Which subtags are required
  • Which data gets sent back to the sender
  • Subtag default data
  • etc.

See Also

API Tags and Subtags Configuration

Example XML

Dovetail Email Agent API Tag XML Structure

Next

Example XML
API Tags XML

Did this topic help you? Email us your feedback.
Last updated: 10/1/2007 4:31:35 PM


Example XML

<tag methodName="move_case" tag="MOVE_CASE" object="CS" inSubject="true" inBody="true" isActive="true">
 <subtags>
  <subTag paramName="case_id" tag="CASE_ID" required="True" />
  <subTag paramName="new_wipbin" tag="NEW_WIPBIN" required="True" />
  <subTag paramName="ret_objid" tag="CASE_OBJID" returnToSender="True" />
  <subTag paramName="ret_id_num" tag="CASE_ID_NUM" returnToSender="True" />
 </subtags>
</tag>

See Also

API Tags and Subtags Configuration

API Tags XML

Dovetail Email Agent API Tag XML Structure

Next

Dovetail Email Agent API Tag XML Structure
Example XML

Did this topic help you? Email us your feedback.
Last updated: 10/9/2007 1:24:26 PM


Dovetail Email Agent API Tag XML Structure

Each single-item tag (like tag, or subtag) is surrounded by a containing tag with a plural name (i.e. tags, subtags respectively). Any attributes on these tags are ignored. These tags serve mainly as groupings or containers to keep the structure. Only the single-item tags will be documented here.

WARNING: All tag and attribute names are CASE SENSITIVE.

See Also

API Tags and Subtags Configuration

API Tags XML

Example XML

Next

<tag> Tag
Dovetail Email Agent API Tag XML Structure

Did this topic help you? Email us your feedback.
Last updated: 10/2/2007 2:11:08 PM


<tag> Tag

Attribute | Required |  | Default | Description
methodName | Yes | N/A |  | Specifies the actual method name on the object to call. NOTE: both this value and the method name for the object are case-sensitive
tag | Yes | N/A |  | The tag or alias to look for in the body or subject of the email. This value is not case sensitive.
object | Yes | N/A |  | Specifies the fully-qualified type and assembly name of the object which contains this method. Please view the Type.GetType() documentation in the .NET Framework SDK for more information on the format of this string.
inSubject | Yes | N/A |  | Determines whether Dovetail Email Agent should allow this tag to appear in the subject line of an email.
inBody | Yes | N/A |  | Determines whether Dovetail Email Agent should allow this tag to appear on the first non-all-whitespace line in the body of an email.
isActive | Yes | N/A |  | Determines whether Dovetail Email Agent should process this tag at all.

See Also

Dovetail Email Agent API Tag XML Structure

<subtag> Tag

Next

<subtag> Tag
<tag> Tag

Did this topic help you? Email us your feedback.
Last updated: 10/9/2007 2:42:24 PM


<subtag> Tag

Attribute

Required

Default

Description

paramName

Yes

N/A

Specifies the actual parameter name for the method/tag.
NOTE: This value can be a property or field name on the object. However, the returnToSender value must also be true.
NOTE: both this value and the parameter name for the actual method, property name, or field name are case-sensitive

tag

Yes

N/A

The tag or alias to look for in the body of the email. This value is not case sensitive.

required

No

False

Determines whether Dovetail Email Agent should require this tag to be present. If it is not present in the email, Dovetail Email Agent will return an error to the originator.

isActive

No

True

Determines whether Dovetail Email Agent should process this subtag at all.

isOutput

No

False

Determines whether Dovetail Email Agent whether this is an 'out' or 'ref' parameter (ByRef in VB.NET). Dovetail Email Agent handles these types of parameters differently.
NOTE: If this value is true, the paramName attribute MUST refer to a method argument and not a property or field.

returnToSender

No

False

Determines whether Dovetail Email Agent should send the value of the parameter/property/field to the user in a reply email (if success reply emails are enabled).

This value can only be true when this subtag is an output parameter or a Property on the class of the method being invoked.

defaultValue

No

(varies by param datatype)

Specifies the value that Dovetail Email Agent should use for this parameter if none was specified by the user.
NOTE: This value is ignored if the paramName value references a property or field or if the required attribute value is true.

See Also

Dovetail Email Agent API Tag XML Structure

<tag> Tag

Next

Custom Contact Validation
<subtag> Tag

Did this topic help you? Email us your feedback.
Last updated: 4/29/2009 2:26:30 PM


Custom Contact Validation

Dovetail Email Agent now supports a plug-in for custom contact validation when creating a case in freeForm mode. This allows customers to add custom validation code to validate whether a contact is allowed to create a case or not.

For example, a customer may wish to only allow cases to be created by contacts with a valid support contract. Or only allow case creation if the primary site of the contact is of a certain type, such as CUST, but not VEND. This plug-in model enables a robust, customizable extension point to Dovetail Email Agent.

To implement this functionality:

  • Create a .NET class (in any .NET language: C#, VB.NET, etc) which implements the IFreeFormContactValidator interface which is located in the Dovetail.Sec.Core assembly/DLL (which is installed to your Dovetail Email Agent installation folder) and then compile the new custom .NET class to an assembly/DLL.
  • Copy this DLL to the Dovetail Email Agent install directory (C:\Program Files\Dovetail Software\Email Agent)
  • Modify email-agent-config.xml, adding a new parameter for the freeFormContactValidatorType. The value should be the fully qualified type name (see note 1 below) of your new .NET class/type and assembly.
    Example:
    <param name="freeFormContactValidatorType" value="MyCompany.SecExtension.Core.ContactValidator, MyCompany.SecExtension.Core, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null" />
  • In the future, when upgrading Dovetail Email Agent to a newer version, it will be necessary to create a 'binding redirection' for .NET to redirect the custom .NET class' dependency on the Dovetail.Sec.Core assembly from the previous version to the latest version. See below for details (see note 3 below).
  • Start the Dovetail Email Agent service

If the validator returns true, then a case will be created.

If the validator returns false, then an email will be sent back to the sender using the FreeformContactValidationFailure.xslt template.

Additional Notes

  • NOTE 1: The rules for 'fully qualified type name' can be found in the MSDN .NET Developer Center under the topic "Type.GetType Method (String)".
  • NOTE 2: If your custom implementation of the IFreeFormContactValidator interface uses the Dovetail SDK or the FChoice.Common assemblies, you must reference the SAME Dovetail SDK and/or FChoice.Common versions that the installed Dovetail Email Agent version is using. If using assembly binding redirection (mentioned below), and the newer version of Dovetail Email Agent references a newer version of the Dovetail SDK also, assembly binding redirection will not be sufficient and a recompile of your custom implementation will be required.
  • NOTE 3: If you build a custom implementation of the IFreeFormContactValidator interface which was based off the Dovetail.Sec.Core version 1.1.0.3, and later you upgrade your Dovetail Email Agent installation to 1.1.1.15, you will not have to rebuild your custom implementation to work with the new Dovetail Email Agent due to a feature of the .NET CLR known as 'assembly binding redirection'. In the EmailAgentService.exe.config file, at the bottom, just before the </configuration> closing XML tag, you will need to add this XML:

    <runtime>
    <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
    <dependentAssembly>
    <assemblyIdentity name="Dovetail.Sec.Core" publicKeyToken="48c955ba8dfd90d8" culture="neutral"/>
    <bindingRedirect oldVersion="8.8.8.8" newVersion="9.9.9.9"/>
    </dependentAssembly>
    </assemblyBinding>
    </runtime>

    IMPORTANT: Remember to change the 'oldVersion' and the 'newVersiion' accordingly where oldVersion is the Dovetail.Sec.Core assembly version against which your custom IFreeFormContactValidator was build and newVersion is the Dovetail.Sec.Core assembly version currently installed.

    IMPORTANT: Check the version history notes in future Dovetail Email Agent releases. It may be necessary for Dovetail Software to break compatibility in the IFreeFormContactValidator interface which would require you to rebuild your custom implementation (binding redirection would not be sufficient in this case). In the event that binary compatibility is broken, there will be a WARNING note in the version history alerting you to this fact.

    For more details, or for a sample custom assembly project, contact Dovetail Software.

Next

Email Template Customization Guide
Custom Contact Validation

Did this topic help you? Email us your feedback.
Last updated: 10/4/2007 3:11:33 PM


Email Template Customization Guide

When Dovetail Email Agent needs to send an outgoing email, it uses a template to determine the format and content of the email. Dovetail Email Agent ships with a set of simple pre-defined templates that can be used. It is expected that most customers will customize these templates. These templates are defined as XSLT files.

Extensible Stylesheet Language Transformations (XSLT) is a styling language for XML. XSLT allows XML in one form to be transformed into another text format, such as HTML. Dovetail Email Agent uses the XSLT templates to produce HTML which is then sent out as an email.

There are many books and websites available that discuss XSLT in great detail. The resources section of www.xslt.com is a good starting point.

In This Chapter

Available XML Data

Templates Shipped with Dovetail Email Agent

Next

Available XML Data
Email Template Customization Guide

Did this topic help you? Email us your feedback.
Last updated: 10/2/2007 4:45:04 PM


Available XML Data

The templates can dynamically include data used in the processing of the email. This allows the content of the email to be dynamically built and then sent. Different templates have different sets of XML data available.

For example, when a new case is created in freeform mode, the case ID number can be sent back to the sender:

Case <xsl:value-of select="//caseID"/> has been successfully created from your email.

The XML tag

<xsl:value-of select="//caseID"/>

will be replaced with the case ID.

See Also

Email Template Customization Guide

Templates Shipped with Dovetail Email Agent

Next

Templates Shipped with Dovetail Email Agent
Available XML Data

Did this topic help you? Email us your feedback.
Last updated: 8/3/2007 2:46:14 PM


Templates Shipped with Dovetail Email Agent

Template | Mode | Description
AdminGeneralError.xslt | Both | If a general Dovetail Email Agent error occurs, this template is used to send an administrator detailed information about the error.
ApiResult.xslt | API Invoke | Returns the result of the API call - success of failure.
EeorsBadAddressReply.xslt | eeoredirect | Some recipients were invalid when sending a message from EEO.
FreeformCantGetContact.xslt | Freeform | Creating a new contact failed.
FreeformCaseCreateFailure.xslt | Freeform | Creating a new case failed.
FreeformCaseCreateSuccess.xslt | Freeform | Creating a new case was successful. Includes the case ID number.
FreeformCaseNotesFailure.xslt | Freeform | Logging Notes to an existing case failed.
FreeformCaseNotesSuccess.xslt | Freeform | Logging Notes to an existing case was successful.
FreeformSubcaseNotesFailure.xslt | Freeform | Logging Notes to an existing subcase failed.
FreeformSubcaseNotesSuccess.xslt | Freeform | Logging Notes to an existing subcase was successful.
FreeformContactValidationFailure.xslt | Freeform | The contact did not pass the custom validation required to create a new case.
FreeformWontCreateCase.xslt | Freeform | The user isn't allowed to create a case due to a configuration setting.
FreeformWontLogNote.xslt | Freeform | The user isn't allowed to log notes to a case due to a configuration setting.
HelpBasic.xslt | API Invoke | Lists all the available API tags that are active.
HelpTag.xslt | API Invoke | For a single API tag, lists all of the required and optional subtags.
HelpTagNotFound.xslt | API Invoke | Informs the sender that the tag they asked for help on is invalid or inactive.

See Also

Email Template Customization Guide

Available XML Data

Next

Admin General Error
Templates Shipped with Dovetail Email Agent

Did this topic help you? Email us your feedback.
Last updated: 10/9/2007 3:34:05 PM


Admin General Error

Available XML Data for the AdminGeneralError Template:

XPath | Description
/processError/@fatal | Indicates if this was a fatal error. True or False.
/processError/generalInfo/severity | Severity of the Error.
/processError/generalInfo/eventId | Identifier that identifies the type of event.
/processError/generalInfo/machineName | Computer name.
/processError/generalInfo/osVersion | Operating System Version.
/processError/generalInfo/timeStamp | Timestamp of error.
/processError/generalInfo/appDomain | .NET application domain.
/processError/generalInfo/threadName | Name of thread in which the error occured.
/processError/generalInfo/threadIdentity | Identitiy of thread in which the error occured.
/processError/generalInfo/windowsIdentity | Identity of user under which the process is being run as.
/processError/errorMessage | Error Message.
/processError/exceptionDetails/@available | Indicates if exception information is available. True or False.
/processError/exceptionDetails | Exception Information. View exception XML Data

See Also

Templates Shipped with Dovetail Email Agent

API Result

Contact Validation Failure

EEORS Bad Address Reply

Exceptions

FreeForm Cant Get Contact

Freeform Case Create Failure

Freeform Case Create Success

Freeform Case Notes Failure

Freeform Case Notes Success

Freeform Subcase Notes Failure

Freeform Subcase Notes Success

Freeform Wont Create Contact

Freeform Wont Create Case

Freeform Wont Log Note

Help Basic

Help Tag

Help Tag Not Found

Next

Example
Admin General Error

Did this topic help you? Email us your feedback.
Last updated: 10/9/2007 2:44:50 PM


Example

The following example shows how to print out the results on a general error.

<table class="propertyList" cellspacing="0" border="1" >
    <caption>Event Details</caption>
    <tr><th nowrap="true" width="1%">Event ID:</th><td><xsl:value-of select="/processError/generalInfo/eventId/@value"/></td></tr>
    <tr><th nowrap="true">Severity:</th><td><xsl:value-of select="/processError/generalInfo/severity/@value"/></td></tr>
    <tr><th nowrap="true">Machine:</th><td><xsl:value-of select="/processError/generalInfo/machineName/@value"/></td></tr>
    <tr><th nowrap="true">OS Ver:</th><td><xsl:value-of select="/processError/generalInfo/osVersion/@value"/></td></tr>
    <tr><th nowrap="true">Time Stamp:</th><td><xsl:value-of select="/processError/generalInfo/timeStamp/@value"/></td></tr>
    <tr><th nowrap="true">App Domain:</th><td><xsl:value-of select="/processError/generalInfo/appDomain"/></td></tr>
    <tr><th nowrap="true">Thread Name:</th><td><xsl:value-of select="/processError/generalInfo/threadName"/></td></tr>
    <tr><th nowrap="true">Thread Identity:</th><td><xsl:value-of select="/processError/generalInfo/threadIdentity"/></td></tr>
    <tr><th nowrap="true">Windows Identity:</th><td><xsl:value-of select="/processError/generalInfo/windowsIdentity"/></td></tr>
</table>

<p>Unable to process message due to the following error message (if available):</p>

<p class="error"><xsl:value-of select="/processError/errorMessage"/></p>

<xsl:if test="/processError/@fatal = 'True'">

 <div class="dottedHR"/>

 <div class="blockArea">

     <p class="warning">

         WARNING: The Super Email Clerk Service daemon thread has shut down and

         will not process this or any other emails until the problem is resolved.

         Please resolve the problem and restart the Super Email Clerk Service to resume processing.

         </p>

 </div>

</xsl:if>

See Also
Admin General Error
Raw XML

Next
Raw XML

 Example

            Did this topic help you? Email us your feedback.

Last updated: 10/9/2007 2:45:00 PM


Raw XML

The following raw XML format is passed to the template during processing:

<?xml version="1.0"?>
<processError fatal="{0}">
    <generalInfo>
        <severity value="{1}"/>
        <eventId value="{2}"/>
        <machineName value="{3}"/>
        <osVersion value="{4}"/>
        <timeStamp value="{5}"/>
        <appDomain><![CDATA[{6}]]></appDomain>
        <threadName><![CDATA[{7}]]></threadName>
        <threadIdentity><![CDATA[{8}]]></threadIdentity>
        <windowsIdentity><![CDATA[{9}]]></windowsIdentity>
    </generalInfo>
    <errorMessage><![CDATA[{10}]]></errorMessage>
    <exceptionDetails available="{11}">
         ** REPEAT {0..n}**
         <exception type="{0}">
            <message>{1}</message>
            <properties>
                ** REPEAT {0..n}** <property name="{0}"><![CDATA[{1}]]></property>
            </properties>
            <stackTrace><![CDATA[{3}]]></stackTrace>
        </exception>
    </exceptionDetails>
</processError>

See Also

Admin General Error

Example

Next

API Result
Raw XML

Did this topic help you? Email us your feedback.
Last updated: 10/9/2007 2:45:07 PM


API Result

Available XML Data for the ApiResult Template:

XPath | Description
/invoke/@tag | The name of the operation tag that was processed.
/invoke/@wasSuccess | Was the API operation available? True or False.
//messageID | Unique email identifier.
//returnVal | The return value from the API call.
/invoke/errorDetails/message | Error Message
/invoke/errorDetails/lineNum | Line number of error
/invoke/errorDetails/exceptionDetails/@available | Indicates if exception information is available. True or False.
/invoke/errorDetails/exceptionDetails | Exception Information. View exception XML Data

See Also

Templates Shipped with Dovetail Email Agent

Admin General Error

Contact Validation Failure

EEORS Bad Address Reply

Exceptions

FreeForm Cant Get Contact

Freeform Case Create Failure

Freeform Case Create Success

Freeform Case Notes Failure

Freeform Case Notes Success

Freeform Subcase Notes Failure

Freeform Subcase Notes Success

Freeform Wont Create Contact

Freeform Wont Create Case

Freeform Wont Log Note

Help Basic

Help Tag

Help Tag Not Found

Next

Example
API Result

Did this topic help you? Email us your feedback.
Last updated: 10/9/2007 2:45:40 PM


Example

The following example shows how to print out the results on an API call:

<p>This message is in reply to your <b><xsl:value-of select="/invoke/@tag"/></b> api request.</p>

<xsl:choose>

   <xsl:when test="/invoke/@wasSuccess = 'True'"><p class="success">The operation completed successfully.</p></xsl:when>

   <xsl:otherwise><p class="failed">The operation FAILED.</p></xsl:otherwise>

</xsl:choose>

<p>

  The return value was:<br/>

  <b><xsl:value-of select="/invoke/returnVal"/></b>

</p>

<xsl:choose>

  <xsl:when test="/invoke/@wasSuccess = 'True'">

    <table class="propertyList" border="1">

      <caption>Operation Results</caption>

      <xsl:for-each select="/invoke/outParams/param">

         <tr><th nowrap="true" width="1%"><xsl:value-of select="@name"/>:</th><td><xsl:value-of select="."/></td></tr>

      </xsl:for-each>

    </table>

   </xsl:when>

   <xsl:otherwise>

       <p>

        The error code returned was:<br/>

        <b class="error"><xsl:value-of select="/invoke/errorDetails/message"/></b>

      </p>

   </xsl:otherwise>

   </xsl:choose>

See Also
API Result
Raw XML

Next
Raw XML

 Example

            Did this topic help you? Email us your feedback.

Last updated: 10/9/2007 1:22:14 PM


Raw XML

The following raw XML format is passed to the template during processing:

<?xml version="1.0"?>

<invoke tag="{0}" wasSuccess="{1}">

    <messageID>{2}</messageID>

    <returnVal><![CDATA[{3}]]></returnVal>

    <errorDetails>

        <message><![CDATA[{4}]]></message>

        <lineNum>{5}</lineNum>

        <exceptionDetails available="{6}">

            ** REPEAT {0..n}**

             <exception type="{0}">

                <message>{1}</message>

                <properties>

                    ** REPEAT {0..n}** <property name="{0}"><![CDATA[{1}]]></property>

                </properties>

                <stackTrace><![CDATA[{3}]]></stackTrace>

            </exception>

        </exceptionDetails>

    </errorDetails>

    <outParams allRetrieved="{8}">

        ** REPEAT {0..n}** <param name="{0}" retrieved="{1}"><![CDATA[{1}]]></param>

    </outParams>

</invoke>

See Also
API Result
Example

Next
Contact Validation Failure

 Raw XML

            Did this topic help you? Email us your feedback.

Last updated: 8/3/2007 2:53:30 PM


Contact Validation Failure

Available XML Data for the FreeformContactValidationFailure Template:

XPath |  | Description
//contactEmail | The email address of the sender of the email.
//messageID | Unique email identifier.

See Also

Templates Shipped with Dovetail Email Agent

Admin General Error

API Result

EEORS Bad Address Reply

Exceptions

FreeForm Cant Get Contact

Freeform Case Create Failure

Freeform Case Create Success

Freeform Case Notes Failure

Freeform Case Notes Success

Freeform Subcase Notes Failure

Freeform Subcase Notes Success

Freeform Wont Create Contact

Freeform Wont Create Case

Freeform Wont Log Note

Help Basic

Help Tag

Help Tag Not Found

Next

Example
Contact Validation Failure

Did this topic help you? Email us your feedback.
Last updated: 10/9/2007 2:46:19 PM


Example

The following example shows how to print out the email address of the sender as well as the unique message identifier:

You are not allowed to create new cases via email.
Resolved customer using email address: <xsl:value-of select="//contactEmail"/>.
Message ID: <xsl:value-of select="//messageID"/>

See Also

Contact Validation Failure

Raw XML

Next

Raw XML
Example

Did this topic help you? Email us your feedback.
Last updated: 8/3/2007 2:54:39 PM


Raw XML

The following raw XML format is passed to the template during processing:

<?xml version="1.0"?>
<contactValidationStatus>
  <messageID>{0}</messageID>
  <contactEmail><![CDATA[{1}]]></contactEmail>
</contactValidationStatus>

See Also

Contact Validation Failure

Example

Next

EEORS Bad Address Reply
Raw XML

Did this topic help you? Email us your feedback.
Last updated: 8/3/2007 2:54:51 PM


EEORS Bad Address Reply

Available XML Data for the EeorsBadAddressReply Template:

XPath | Description
//messageID | Unique Message ID of the original message sent from EEO.
//badAddr | A list of bad addresses.
//badAddr[0]/value | The email address of a specific (first, in this case) bad addresses.
//badAddr[0]/reason | The failure reason of a specific (first, in this case) bad address.

See Also

Templates Shipped with Dovetail Email Agent

Admin General Error

API Result

Contact Validation Failure

Exceptions

FreeForm Cant Get Contact

Freeform Case Create Failure

Freeform Case Create Success

Freeform Case Notes Failure

Freeform Case Notes Success

Freeform Subcase Notes Failure

Freeform Subcase Notes Success

Freeform Wont Create Contact

Freeform Wont Create Case

Freeform Wont Log Note

Help Basic

Help Tag

Help Tag Not Found

Next

Example
EEORS Bad Address Reply

Did this topic help you? Email us your feedback.
Last updated: 10/9/2007 2:47:07 PM


Example

The following example shows how to print a list of bad address:

<ul>
<xsl:for-each select="//badAddr">
  <li><xsl:value-of select="value"/></li>
</xsl:for-each>
</ul>

See Also

EEORS Bad Address Reply

Raw XML

Next

Raw XML
Example

Did this topic help you? Email us your feedback.
Last updated: 8/3/2007 2:55:14 PM


Raw XML

The following raw XML format is passed to the template during processing:

<?xml version="1.0"?>
<badAddrList>
    <messageID>{0}</messageID>
    <badAddr> ** REPEAT {0..n}**
        <value>{1}</value>
        <reason>{2}</reason>
    </badAddr>
</badAddrList>

See Also

EEORS Bad Address Reply

Example

Next

Exceptions
Raw XML

Did this topic help you? Email us your feedback.
Last updated: 8/3/2007 2:55:27 PM


Exceptions

Available XML Data for Exceptions:

XPath | Description
/exceptionDetails/@available | Are exception details available? True or False.
/exceptionDetails/exception/@type | The type of exception. Note that there can be multiple exception elements contained within exceptionDetails.
/exceptionDetails/exception/message | The exception message string.
/exceptionDetails/exception/properties/property/@name | The name of the property. Note that there can be multiple property elements contained within properties.
/exceptionDetails/exception/properties/property/ | The value of the property.
/exceptionDetails/exception/stackTrace | The stack trace details of the exception

See Also

Templates Shipped with Dovetail Email Agent

Admin General Error

API Result

Contact Validation Failure

EEORS Bad Address Reply

FreeForm Cant Get Contact

Freeform Case Create Failure

Freeform Case Create Success

Freeform Case Notes Failure

Freeform Case Notes Success

Freeform Subcase Notes Failure

Freeform Subcase Notes Success

Freeform Wont Create Contact

Freeform Wont Create Case

Freeform Wont Log Note

Help Basic

Help Tag

Help Tag Not Found

Next

Example
Exceptions

Did this topic help you? Email us your feedback.
Last updated: 10/9/2007 2:47:38 PM


Example

Examine the ApiResult.xslt file for an example of formatting and displaying exception details.

See Also

Exceptions

Raw XML

Next

Raw XML
Example

Did this topic help you? Email us your feedback.
Last updated: 8/3/2007 10:04:40 AM


Raw XML

The following raw XML format is passed to the template during processing:

    <exceptionDetails available="{3}">
        ** REPEAT {0..n}**
         <exception type="{0}">
            <message>{1}</message>
            <properties>
                ** REPEAT {0..n}** <property name="{0}"><![CDATA[{1}]]></property>
            </properties>
            <stackTrace><![CDATA[{3}]]></stackTrace>
        </exception>
    </exceptionDetails>

See Also

Exceptions

Example

Next

FreeForm Cant Get Contact
Raw XML

Did this topic help you? Email us your feedback.
Last updated: 8/3/2007 2:56:03 PM


FreeForm Cant Get Contact

Available XML Data for the FreeformCantGetContact and FreeformWontCreateContact Templates:

XPath | Description
//contactCreateStatus/@attemptToCreate | Did Dovetail Email Agent attempt to create the contact? True or False.
//contactEmail | The email address of the sender of the email.
//messageID | Unique email identifier.

See Also

Templates Shipped with Dovetail Email Agent

Admin General Error

API Result

Contact Validation Failure

EEORS Bad Address Reply

Exceptions

Freeform Case Create Failure

Freeform Case Create Success

Freeform Case Notes Failure

Freeform Case Notes Success

Freeform Subcase Notes Failure

Freeform Subcase Notes Success

Freeform Wont Create Contact

Freeform Wont Create Case

Freeform Wont Log Note

Help Basic

Help Tag

Help Tag Not Found

Next

Example
FreeForm Cant Get Contact

Did this topic help you? Email us your feedback.
Last updated: 10/9/2007 2:48:06 PM


Example

The following example shows how to print out the email address of the sender as well as the unique message identifier:

We were unable to find a match in our database for your email address (<xsl:value-of select="//contactEmail"/>).
Message ID: <xsl:value-of select="//messageID"/>

See Also

FreeForm Cant Get Contact

Raw XML

Next

Raw XML
Example

Did this topic help you? Email us your feedback.
Last updated: 8/3/2007 2:57:32 PM


Raw XML

The following raw XML format is passed to the template during processing:

<?xml version="1.0"?>
<contactCreateStatus attemptToCreate="{0}">
  <messageID>{1}</messageID>
  <contactEmail><![CDATA[{2}]]></contactEmail>
</contactCreateStatus>

See Also

FreeForm Cant Get Contact

Example

Next

Freeform Case Create Failure
Raw XML

Did this topic help you? Email us your feedback.
Last updated: 8/3/2007 2:57:50 PM


Freeform Case Create Failure

Available XML Data for the FreeformCaseCreateFailure and FreeformCaseCreateSuccess Templates:

XPath | Description
//caseCreateStatus/@wasSuccess |  | Was the Case Creation succesful? True of False.
//messageID |  | Unique email identifier.
//contactEmail |  | The email address of the sender of the email.
//caseID/@available |  | Is there a Case ID number available? True of False.
//caseID |  | Case ID number.
//errorMessage/@available |  | Is there an error message available? True of False.
//errorMessage |  | Error Message.
/caseCreateStatus/exceptionDetails/ |  | Exception Information. View exception XML Data

See Also

Templates Shipped with Dovetail Email Agent

Admin General Error

API Result

Contact Validation Failure

EEORS Bad Address Reply

Exceptions

FreeForm Cant Get Contact

Freeform Case Create Success

Freeform Case Notes Failure

Freeform Case Notes Success

Freeform Subcase Notes Failure

Freeform Subcase Notes Success

Freeform Wont Create Contact

Freeform Wont Create Case

Freeform Wont Log Note

Help Basic

Help Tag

Help Tag Not Found

Next

Example
Freeform Case Create Failure

Did this topic help you? Email us your feedback.
Last updated: 10/9/2007 2:49:36 PM


Example

The following example shows how to print out the ID number of the case that was just created:

<p>Case <xsl:value-of select="//caseID"/> has been successfully created from your email.</p>

See Also

Freeform Case Create Failure

Raw XML

Next

Raw XML
Example

Did this topic help you? Email us your feedback.
Last updated: 8/3/2007 2:58:12 PM


Raw XML

The following raw XML format is passed to the template during processing:

<?xml version="1.0"?>
<caseCreateStatus wasSuccess="{0}">
    <messageID>{1}</messageID>
    <contactEmail><![CDATA[{2}]]></contactEmail>
    <caseID available="{3}"><![CDATA[{4}]]></caseID>
    <errorMessage available="{5}">{6}</errorMessage>
    <exceptionDetails available="{5}">
        ** REPEAT {0..n}**
         <exception type="{0}">
            <message>{1}</message>
            <properties>
                ** REPEAT {0..n}** <property name="{0}"><![CDATA[{1}]]></property>
            </properties>
            <stackTrace><![CDATA[{3}]]></stackTrace>
        </exception>
    </exceptionDetails>
</caseCreateStatus>

See Also

Freeform Case Create Failure

Example

Next

Freeform Case Create Success
Raw XML

Did this topic help you? Email us your feedback.
Last updated: 8/3/2007 2:58:39 PM


Freeform Case Create Success

Available XML Data for the FreeformCaseCreateFailure and FreeformCaseCreateSuccess Templates:

XPath | Description
//caseCreateStatus/@wasSuccess |  | Was the Case Creation succesful? True of False.
//messageID |  | Unique email identifier.
//contactEmail |  | The email address of the sender of the email.
//caseID/@available |  | Is there a Case ID number available? True of False.
//caseID |  | Case ID number.
//errorMessage/@available |  | Is there an error message available? True of False.
//errorMessage |  | Error Message.
/caseCreateStatus/exceptionDetails/ |  | Exception Information. View exception XML Data

See Also

Templates Shipped with Dovetail Email Agent

Admin General Error

API Result

Contact Validation Failure

EEORS Bad Address Reply

Exceptions

FreeForm Cant Get Contact

Freeform Case Create Failure

Freeform Case Notes Failure

Freeform Case Notes Success

Freeform Subcase Notes Failure

Freeform Subcase Notes Success

Freeform Wont Create Contact

Freeform Wont Create Case

Freeform Wont Log Note

Help Basic

Help Tag

Help Tag Not Found

Next

Example
Freeform Case Create Success

Did this topic help you? Email us your feedback.
Last updated: 10/9/2007 2:50:08 PM


Example

The following example shows how to print out the ID number of the case that was just created:

<p>Case <xsl:value-of select="//caseID"/> has been successfully created from your email.</p>

See Also

Freeform Case Create Success

Raw XML

Next

Raw XML
Example

Did this topic help you? Email us your feedback.
Last updated: 8/3/2007 2:59:16 PM


Raw XML

The following raw XML format is passed to the template during processing:

<?xml version="1.0"?>
<caseCreateStatus wasSuccess="{0}">
    <messageID>{1}</messageID>
    <contactEmail><![CDATA[{2}]]></contactEmail>
    <caseID available="{3}"><![CDATA[{4}]]></caseID>
    <errorMessage available="{5}">{6}</errorMessage>
    <exceptionDetails available="{5}">
        ** REPEAT {0..n}**
         <exception type="{0}">
            <message>{1}</message>
            <properties>
                ** REPEAT {0..n}** <property name="{0}"><![CDATA[{1}]]></property>
            </properties>
            <stackTrace><![CDATA[{3}]]></stackTrace>
        </exception>
    </exceptionDetails>
</caseCreateStatus>

See Also

Freeform Case Create Success

Example

Next

Freeform Case Notes Failure
Raw XML

Did this topic help you? Email us your feedback.
Last updated: 8/3/2007 2:59:34 PM


Freeform Case Notes Failure

Available XML Data for Templates:

  • FreeformCaseNotesFailure
  • FreeformCaseNotesSuccess
  • FreeformSubcaseNotesFailure
  • FreeformSubcaseNotesSuccess

XPath | Description
/logNotesStatus/@wasSuccess | Was the Log Notes Operation successful or not? True or False.
//messageID | Unique Email Message Identifier.
//notes | The notes that were logged.
/logNotesStatus/exceptionDetails/ | Exception Information. View exception XML Data

See Also

Templates Shipped with Dovetail Email Agent

Admin General Error

API Result

Contact Validation Failure

EEORS Bad Address Reply

Exceptions

FreeForm Cant Get Contact

Freeform Case Create Failure

Freeform Case Create Success

Freeform Case Notes Success

Freeform Subcase Notes Failure

Freeform Subcase Notes Success

Freeform Wont Create Contact

Freeform Wont Create Case

Freeform Wont Log Note

Help Basic

Help Tag

Help Tag Not Found

Next

Raw XML
Freeform Case Notes Failure

Did this topic help you? Email us your feedback.
Last updated: 10/9/2007 2:50:45 PM


Raw XML

The following raw XML format is passed to the template during processing:

<?xml version="1.0"?>
<logNotesStatus wasSuccess="{0}">
    <messageID>{1}</messageID>
    <notes><![CDATA[{2}]]></notes>
    <exceptionDetails available="{3}">
        ** REPEAT {0..n}**
         <exception type="{0}">
            <message>{1}</message>
            <properties>
                ** REPEAT {0..n}** <property name="{0}"><![CDATA[{1}]]></property>
            </properties>
            <stackTrace><![CDATA[{3}]]></stackTrace>
        </exception>
    </exceptionDetails>
</logNotesStatus>

See Also

Freeform Case Notes Failure

Next

Freeform Case Notes Success
Raw XML

Did this topic help you? Email us your feedback.
Last updated: 8/3/2007 2:59:59 PM


Freeform Case Notes Success

Available XML Data for Templates:

  • FreeformCaseNotesFailure
  • FreeformCaseNotesSuccess
  • FreeformSubcaseNotesFailure
  • FreeformSubcaseNotesSuccess

XPath | Description
/logNotesStatus/@wasSuccess | Was the Log Notes Operation successful or not? True or False.
//messageID | Unique Email Message Identifier.
//notes | The notes that were logged.
/logNotesStatus/exceptionDetails/ | Exception Information. View exception XML Data

See Also

Templates Shipped with Dovetail Email Agent

Admin General Error

API Result

Contact Validation Failure

EEORS Bad Address Reply

Exceptions

FreeForm Cant Get Contact

Freeform Case Create Failure

Freeform Case Create Success

Freeform Case Notes Failure

Freeform Subcase Notes Failure

Freeform Subcase Notes Success

Freeform Wont Create Contact

Freeform Wont Create Case

Freeform Wont Log Note

Help Basic

Help Tag

Help Tag Not Found

Next

Raw XML
Freeform Case Notes Success

Did this topic help you? Email us your feedback.
Last updated: 10/9/2007 2:51:23 PM


Raw XML

The following raw XML format is passed to the template during processing:

<?xml version="1.0"?>
<logNotesStatus wasSuccess="{0}">
    <messageID>{1}</messageID>
    <notes><![CDATA[{2}]]></notes>
    <exceptionDetails available="{3}">
        ** REPEAT {0..n}**
         <exception type="{0}">
            <message>{1}</message>
            <properties>
                ** REPEAT {0..n}** <property name="{0}"><![CDATA[{1}]]></property>
            </properties>
            <stackTrace><![CDATA[{3}]]></stackTrace>
        </exception>
    </exceptionDetails>
</logNotesStatus>

See Also

Freeform Case Notes Success

Next

Freeform Subcase Notes Failure
Raw XML

Did this topic help you? Email us your feedback.
Last updated: 8/3/2007 3:00:29 PM


Freeform Subcase Notes Failure

Available XML Data for Templates:

  • FreeformCaseNotesFailure
  • FreeformCaseNotesSuccess
  • FreeformSubcaseNotesFailure
  • FreeformSubcaseNotesSuccess

XPath | Description
/logNotesStatus/@wasSuccess | Was the Log Notes Operation successful or not? True or False.
//messageID | Unique Email Message Identifier.
//notes | The notes that were logged.
/logNotesStatus/exceptionDetails/ | Exception Information. View exception XML Data

See Also

Templates Shipped with Dovetail Email Agent

Admin General Error

API Result

Contact Validation Failure

EEORS Bad Address Reply

Exceptions

FreeForm Cant Get Contact

Freeform Case Create Failure

Freeform Case Create Success

Freeform Case Notes Failure

Freeform Case Notes Success

Freeform Subcase Notes Success

Freeform Wont Create Contact

Freeform Wont Create Case

Freeform Wont Log Note

Help Basic

Help Tag

Help Tag Not Found

Next

Raw XML
Freeform Subcase Notes Failure

Did this topic help you? Email us your feedback.
Last updated: 10/9/2007 2:51:52 PM


Raw XML

The following raw XML format is passed to the template during processing:

<?xml version="1.0"?>
<logNotesStatus wasSuccess="{0}">
    <messageID>{1}</messageID>
    <notes><![CDATA[{2}]]></notes>
    <exceptionDetails available="{3}">
        ** REPEAT {0..n}**
         <exception type="{0}">
            <message>{1}</message>
            <properties>
                ** REPEAT {0..n}** <property name="{0}"><![CDATA[{1}]]></property>
            </properties>
            <stackTrace><![CDATA[{3}]]></stackTrace>
        </exception>
    </exceptionDetails>
</logNotesStatus>

See Also

Freeform Subcase Notes Failure

Next

Freeform Subcase Notes Success
Raw XML

Did this topic help you? Email us your feedback.
Last updated: 8/3/2007 3:00:53 PM


Freeform Subcase Notes Success

Available XML Data for Templates:

  • FreeformCaseNotesFailure
  • FreeformCaseNotesSuccess
  • FreeformSubcaseNotesFailure
  • FreeformSubcaseNotesSuccess

XPath | Description
/logNotesStatus/@wasSuccess | Was the Log Notes Operation successful or not? True or False.
//messageID | Unique Email Message Identifier.
//notes | The notes that were logged.
/logNotesStatus/exceptionDetails/ | Exception Information. View exception XML Data

See Also

Templates Shipped with Dovetail Email Agent

Admin General Error

API Result

Contact Validation Failure

EEORS Bad Address Reply

Exceptions

FreeForm Cant Get Contact

Freeform Case Create Failure

Freeform Case Create Success

Freeform Case Notes Failure

Freeform Case Notes Success

Freeform Subcase Notes Failure

Freeform Wont Create Contact

Freeform Wont Create Case

Freeform Wont Log Note

Help Basic

Help Tag

Help Tag Not Found

Next

Raw XML
Freeform Subcase Notes Success

Did this topic help you? Email us your feedback.
Last updated: 10/9/2007 2:52:23 PM


Raw XML

The following raw XML format is passed to the template during processing:

<?xml version="1.0"?>
<logNotesStatus wasSuccess="{0}">
    <messageID>{1}</messageID>
    <notes><![CDATA[{2}]]></notes>
    <exceptionDetails available="{3}">
        ** REPEAT {0..n}**
         <exception type="{0}">
            <message>{1}</message>
            <properties>
                ** REPEAT {0..n}** <property name="{0}"><![CDATA[{1}]]></property>
            </properties>
            <stackTrace><![CDATA[{3}]]></stackTrace>
        </exception>
    </exceptionDetails>
</logNotesStatus>

See Also

Freeform Subcase Notes Success

Next

Freeform Wont Create Contact
Raw XML

Did this topic help you? Email us your feedback.
Last updated: 8/3/2007 3:01:15 PM


Freeform Wont Create Contact

Available XML Data for the FreeformCantGetContact and FreeformWontCreateContact Templates:

XPath | Description
//contactCreateStatus/@attemptToCreate | Did Dovetail Email Agent attempt to create the contact? True or False.
//contactEmail | The email address of the sender of the email.
//messageID | Unique email identifier.

See Also

Templates Shipped with Dovetail Email Agent

Admin General Error

API Result

Contact Validation Failure

EEORS Bad Address Reply

Exceptions

FreeForm Cant Get Contact

Freeform Case Create Failure

Freeform Case Create Success

Freeform Case Notes Failure

Freeform Case Notes Success

Freeform Subcase Notes Failure

Freeform Subcase Notes Success

Freeform Wont Create Case

Freeform Wont Log Note

Help Basic

Help Tag

Help Tag Not Found

Next

Example
Freeform Wont Create Contact

Did this topic help you? Email us your feedback.
Last updated: 10/9/2007 3:35:35 PM


Example

The following example shows how to print out the email address of the sender as well as the unique message identifier:

We were unable to find a match in our database for your email address (<xsl:value-of select="//contactEmail"/>).
Message ID: <xsl:value-of select="//messageID"/>

See Also

Freeform Wont Create Contact

Raw XML

Next

Raw XML
Example

Did this topic help you? Email us your feedback.
Last updated: 8/3/2007 3:01:47 PM


Raw XML

The following raw XML format is passed to the template during processing:

<?xml version="1.0"?>
<contactCreateStatus attemptToCreate="{0}">
  <messageID>{1}</messageID>
  <contactEmail><![CDATA[{2}]]></contactEmail>
</contactCreateStatus>

See Also

Freeform Wont Create Contact

Example

Next

Freeform Wont Create Case
Raw XML

Did this topic help you? Email us your feedback.
Last updated: 8/3/2007 3:01:59 PM


Freeform Wont Create Case

Available XML Data for the FreeformWontCreateCase Template.

XPath | Description
//messageID | Unique Email Message Identifier.

See Also

Templates Shipped with Dovetail Email Agent

Admin General Error

API Result

Contact Validation Failure

EEORS Bad Address Reply

Exceptions

FreeForm Cant Get Contact

Freeform Case Create Failure

Freeform Case Create Success

Freeform Case Notes Failure

Freeform Case Notes Success

Freeform Subcase Notes Failure

Freeform Subcase Notes Success

Freeform Wont Create Contact

Freeform Wont Log Note

Help Basic

Help Tag

Help Tag Not Found

Next

Raw XML
Freeform Wont Create Case

Did this topic help you? Email us your feedback.
Last updated: 10/9/2007 3:11:20 PM


Raw XML

The following raw XML format is passed to the template during processing:

<?xml version="1.0" encoding="UTF-8" ?>
<xsl:stylesheet version="1.0" xmlns:xsl="http://www.w3.org/1999/XSL/Transform">
<xsl:output method="html" doctype-public="-//W3C//DTD HTML 4.01//EN" doctype-system="http://www.w3.org/TR/html4/strict.dtd"/>
<xsl:template match="/">
    <html>
        <head>
            <title>Unable to process your email</title>
            <style>
                body { font-family: Verdana,Sans-Serif; font-size: x-small; color: #444444; background-color: #dcdcdc;}
                h1{color: #444444;font-size:1.4em;margin:5px;}
                p{font-size:1.05em;}
                div.bodyArea{width:500px;border:1px solid gray;background-color: white;}
                div.bodyHeader{padding:5px;border-bottom:1px solid gray;background-color: whitesmoke;}
                div.blockArea{padding-left:10px;padding-right:10px;margin-top:10px;margin-bottom:5px;}
            </style>
        </head>

        <body>
            <div class="bodyArea">
                <div class="bodyHeader"><h1>Unable to process your email</h1></div>

                <div class="blockArea" >
                    <p>
                        We were unable to process your email.
                        Case creation is not allowed.
                        Details of this issue have been forwarded to our administrator.
                        If you need further assistance, please contact us and reference the following ID number:
                    </p>
                    <p>
                        Message ID: <xsl:value-of select="//messageID"/>
                    </p>
                </div>
            </div>
        </body>
    </html>
</xsl:template>

</xsl:stylesheet>

See Also
Freeform Wont Create Case

Next
Freeform Wont Log Note

 Raw XML

            Did this topic help you? Email us your feedback.

Last updated: 10/9/2007 3:16:04 PM


Freeform Wont Log Note

Available XML Data for the FreeformWontLogNote Template.

XPath | Description
//messageID | Unique Email Message Identifier.

See Also

Templates Shipped with Dovetail Email Agent

Admin General Error

API Result

Contact Validation Failure

EEORS Bad Address Reply

Exceptions

FreeForm Cant Get Contact

Freeform Case Create Failure

Freeform Case Create Success

Freeform Case Notes Failure

Freeform Case Notes Success

Freeform Subcase Notes Failure

Freeform Subcase Notes Success

Freeform Wont Create Contact

Freeform Wont Create Case

Help Basic

Help Tag

Help Tag Not Found

Next

Raw XML
Freeform Wont Log Note

Did this topic help you? Email us your feedback.
Last updated: 10/9/2007 3:11:37 PM


Raw XML

The following raw XML format is passed to the template during processing:

<?xml version="1.0" encoding="UTF-8" ?>
<xsl:stylesheet version="1.0" xmlns:xsl="http://www.w3.org/1999/XSL/Transform">
<xsl:output method="html" doctype-public="-//W3C//DTD HTML 4.01//EN" doctype-system="http://www.w3.org/TR/html4/strict.dtd"/>
<xsl:template match="/">
    <html>
        <head>
            <title>Unable to process your email</title>
            <style>
                body { font-family: Verdana,Sans-Serif; font-size: x-small; color: #444444; background-color: #dcdcdc;}
                h1{color: #444444;font-size:1.4em;margin:5px;}
                p{font-size:1.05em;}
                div.bodyArea{width:500px;border:1px solid gray;background-color: white;}
                div.bodyHeader{padding:5px;border-bottom:1px solid gray;background-color: whitesmoke;}
                div.blockArea{padding-left:10px;padding-right:10px;margin-top:10px;margin-bottom:5px;}
            </style>
        </head>

        <body>
            <div class="bodyArea">
                <div class="bodyHeader"><h1>Unable to process your email</h1></div>

                <div class="blockArea" >
                    <p>
                        We were unable to process your email.
                        Logging notes is not allowed.
                        Details of this issue have been forwarded to our administrator.
                        If you need further assistance, please contact us and reference the following ID number:
                    </p>
                    <p>
                        Message ID: <xsl:value-of select="//messageID"/>
                    </p>
                </div>
            </div>
        </body>
    </html>
</xsl:template>

</xsl:stylesheet>

See Also
Freeform Wont Log Note

Next
Help Basic

 Raw XML

            Did this topic help you? Email us your feedback.

Last updated: 10/9/2007 3:15:53 PM


Help Basic

Available XML Data for the HelpBasic Templates:

XPath |  | Description
//tag/@name | The name of the active tag for this daemon. Note that there can be multiple active tags.

See Also

Templates Shipped with Dovetail Email Agent

Admin General Error

API Result

Contact Validation Failure

EEORS Bad Address Reply

Exceptions

FreeForm Cant Get Contact

Freeform Case Create Failure

Freeform Case Create Success

Freeform Case Notes Failure

Freeform Case Notes Success

Freeform Subcase Notes Failure

Freeform Subcase Notes Success

Freeform Wont Create Contact

Freeform Wont Create Case

Freeform Wont Log Note

Help Tag

Help Tag Not Found

Next

Example
Help Basic

Did this topic help you? Email us your feedback.
Last updated: 10/9/2007 3:36:14 PM


Example

The following example shows how to print out all of the active tags:

<xsl:for-each select="//tag">
   <xsl:value-of select="@name"/><br/>
</xsl:for-each>

See Also

Help Basic

Raw XML

Next

Raw XML
Example

Did this topic help you? Email us your feedback.
Last updated: 8/3/2007 3:02:18 PM


Raw XML

The following raw XML format is passed to the template during processing:

<?xml version="1.0"?>
<tags>
    ** REPEAT {0..n} **<tag name="{0}"/>
</tags>

See Also

Help Basic

Example

Next

Help Tag
Raw XML

Did this topic help you? Email us your feedback.
Last updated: 8/3/2007 3:02:26 PM


Help Tag

Available XML Data for the HelpTag and HelpTagNotFound Templates:

XPath | Description
//tag/@name | The name of the tag that help was requested on.
//tag/@inSubject | Indicates if the tag must be on the subject line. True of False.
//tag/@inBody | Indicates if the tag must be on the first line of the body. True of False.
//tag/param/@name | Name of the subtag. Note that there can be multiple param elements for a tag.
//tag/param/@required | Indicates if the subtag is required or not. True or False.

See Also

Templates Shipped with Dovetail Email Agent

Admin General Error

API Result

Contact Validation Failure

EEORS Bad Address Reply

Exceptions

FreeForm Cant Get Contact

Freeform Case Create Failure

Freeform Case Create Success

Freeform Case Notes Failure

Freeform Case Notes Success

Freeform Subcase Notes Failure

Freeform Subcase Notes Success

Freeform Wont Create Contact

Freeform Wont Create Case

Freeform Wont Log Note

Help Basic

Help Tag Not Found

Next

Example
Help Tag

Did this topic help you? Email us your feedback.
Last updated: 10/9/2007 3:36:38 PM


Example

The following example shows how to print out the tag, its properties, and its required and optional subtags:

<p>
  <xsl:if test="(//tag/@inSubject = 'True') and (//tag/@inBody = 'True')">
    The operation tag must be on the subject line or on the first line of the body.
  </xsl:if>
  <xsl:if test="(//tag/@inSubject = 'True') and (//tag/@inBody = 'False')">
    The operation tag must be on the subject line.
  </xsl:if>
  <xsl:if test="(//tag/@inSubject = 'False') and (//tag/@inBody = 'True')">
    The operation tag must be on the first line of the body.
  </xsl:if>
</p>

<p>

  Operation tag is:<br/>

  <b><xsl:value-of select="//tag/@name"/></b>

</p>

<p>

  <table class="propertyList" border="1">

    <caption>Required Parameters</caption>

    <xsl:for-each select="//tag/param[@required = 'True']">

      <tr><td><xsl:value-of select="@name"/></td></tr>

    </xsl:for-each>

  </table>

</p>

<p>

  <table class="propertyList" border="1">

    <caption>Optional Parameters</caption>

    <xsl:for-each select="//tag/param[@required = 'False']">

      <tr><td><xsl:value-of select="@name"/></td></tr>

    </xsl:for-each>

  </table>

</p>

See Also
Help Tag
Raw XML

Next
Raw XML

 Example

            Did this topic help you? Email us your feedback.

Last updated: 8/3/2007 3:02:47 PM


Raw XML

The following raw XML format is passed to the template during processing:

<?xml version="1.0"?>
<tag name="{0}" inSubject="{1}" inBody="{2}">
    ** REPEAT {0..n} ** <param name="{0}" required="{1}"/>
</tag>

See Also

Help Tag

Example

Next

Help Tag Not Found
Raw XML

Did this topic help you? Email us your feedback.
Last updated: 8/3/2007 3:02:55 PM


Help Tag Not Found

Available XML Data for the HelpTag and HelpTagNotFound Templates:

XPath | Description
//tag/@name | The name of the tag that help was requested on.
//tag/@inSubject | Indicates if the tag must be on the subject line. True of False.
//tag/@inBody | Indicates if the tag must be on the first line of the body. True of False.
//tag/param/@name | Name of the subtag. Note that there can be multiple param elements for a tag.
//tag/param/@required | Indicates if the subtag is required or not. True or False.

See Also

Templates Shipped with Dovetail Email Agent

Admin General Error

API Result

Contact Validation Failure

EEORS Bad Address Reply

Exceptions

FreeForm Cant Get Contact

Freeform Case Create Failure

Freeform Case Create Success

Freeform Case Notes Failure

Freeform Case Notes Success

Freeform Subcase Notes Failure

Freeform Subcase Notes Success

Freeform Wont Create Contact

Freeform Wont Create Case

Freeform Wont Log Note

Help Basic

Help Tag

Next

Example
Help Tag Not Found

Did this topic help you? Email us your feedback.
Last updated: 10/9/2007 3:37:13 PM


Example

The following example shows how to print out the tag, its properties, and its required and optional subtags:

<p>
  <xsl:if test="(//tag/@inSubject = 'True') and (//tag/@inBody = 'True')">
    The operation tag must be on the subject line or on the first line of the body.
  </xsl:if>
  <xsl:if test="(//tag/@inSubject = 'True') and (//tag/@inBody = 'False')">
    The operation tag must be on the subject line.
  </xsl:if>
  <xsl:if test="(//tag/@inSubject = 'False') and (//tag/@inBody = 'True')">
    The operation tag must be on the first line of the body.
  </xsl:if>
</p>

<p>

  Operation tag is:<br/>

  <b><xsl:value-of select="//tag/@name"/></b>

</p>

<p>

  <table class="propertyList" border="1">

    <caption>Required Parameters</caption>

    <xsl:for-each select="//tag/param[@required = 'True']">

      <tr><td><xsl:value-of select="@name"/></td></tr>

    </xsl:for-each>

  </table>

</p>

<p>

  <table class="propertyList" border="1">

    <caption>Optional Parameters</caption>

    <xsl:for-each select="//tag/param[@required = 'False']">

      <tr><td><xsl:value-of select="@name"/></td></tr>

    </xsl:for-each>

  </table>

</p>

See Also
Help Tag Not Found
Raw XML

Next
Raw XML

 Example

            Did this topic help you? Email us your feedback.

Last updated: 8/3/2007 3:03:12 PM


Raw XML

The following raw XML format is passed to the template during processing:

<?xml version="1.0"?>
<tag name="{0}" inSubject="{1}" inBody="{2}">
    ** REPEAT {0..n} ** <param name="{0}" required="{1}"/>
</tag>

See Also

Help Tag Not Found

Example

Next

Using Custom Case ID Numbering Schemes
Raw XML

Did this topic help you? Email us your feedback.
Last updated: 8/3/2007 3:03:20 PM


Using Custom Case ID Numbering Schemes

When processing freeform emails, special considerations are needed when dealing with case id numbering schemes that have spaces or dashes.

In This Chapter

Case ID Numbering Schemes with Dashes

Case ID Numbering Schemes with Spaces

Next

Case ID Numbering Schemes with Dashes
Using Custom Case ID Numbering Schemes

Did this topic help you? Email us your feedback.
Last updated: 8/16/2007 3:26:50 PM


Case ID Numbering Schemes with Dashes

When Dovetail Email Agent processes a freeform email, it can log notes to a case or a subcase. It parses the subject or body to find the ID number. For example, an email with a subject of "About Case 123" will cause Dovetail Email Agent to log notes to case 123. To distinguish cases from subcases, Dovetail Email Agent looks for a dash in the ID number. If it finds a dash, it assumes that it is a subcase.

Example:
"About case 123" will cause Dovetail Email Agent to log notes to case 123.
"About case 123-1" will cause Dovetail Email Agent to log notes to subcase 123-1.

Case ID Numbering Schemes which contain dashes can disrupt this processing. For example: "About case 123-01052005" will cause Dovetail Email Agent to attempt to log notes to subcase 123-01052005, which will fail, as 123-01052005 is a case ID, not a subcase ID.

To handle this situation, Dovetail Email Agent has a configuration parameter named "numberDashesInCaseId". Simply set this parameter to the number of dashes in your Case ID numbering scheme. So, if numberDashesInCaseId is set to 1, then the following example would work in this manner: "About case 123-01052005" will cause Dovetail Email Agent to log notes to case 123-01052005. "About case 123-01052005-1" will cause Dovetail Email Agent to log notes to subcase 123-01052005-1. Variable number of dashes in the Case ID number scheme are not currently supported by Dovetail Email Agent.

See Also

Using Custom Case ID Numbering Schemes

Case ID Numbering Schemes with Spaces

Next

Case ID Numbering Schemes with Spaces
Case ID Numbering Schemes with Dashes

Did this topic help you? Email us your feedback.
Last updated: 10/2/2007 2:13:08 PM


Case ID Numbering Schemes with Spaces

When Dovetail Email Agent processes a freeform email, it can log notes to a case or a subcase. It parses the subject or body to find the ID number. For example, an email with a subject of "About Case 123" will cause Dovetail Email Agent to log notes to case 123. In addition, Dovetail Email Agent can handle additional text after the case ID. Example: "About Case 123 support request" will cause Dovetail Email Agent to log notes to case 123.

However, Case ID Numbering Schemes which contain spaces can cause this parsing to fail.

Example:
"About Case 123 01052005" will cause Dovetail Email Agent to attempt to log notes to case 123, which will fail, as the ID number is "123 01052005", not "123".

To handle this situation, Dovetail Email Agent has a configuration parameter named "freeFormTextAfterID". If your Case ID Numbering Scheme contains spaces, simply set this parameter to false. So, if freeFormTextAfterID is set to false, then the following example will work:

"About Case 123 01052005" will cause Dovetail Email Agent to log notes to case 123 01052005.

See Also

Using Custom Case ID Numbering Schemes

Case ID Numbering Schemes with Dashes

Next

Example Emails
Case ID Numbering Schemes with Spaces

Did this topic help you? Email us your feedback.
Last updated: 10/2/2007 2:13:21 PM


Example Emails

The following email examples illustrate emails that can be processed by Dovetail Email Agent.

In This Chapter

Freeform Mode

API Invoke Mode

Next

Freeform Mode
Example Emails

Did this topic help you? Email us your feedback.
Last updated: 10/4/2007 11:52:10 AM


Freeform Mode

See Also

Example Emails

API Invoke Mode

Next

Log Email In
Freeform Mode

Did this topic help you? Email us your feedback.
Last updated: 10/4/2007 11:53:01 AM


Log Email In

SUBJECT:

This is the subject - About case 540

BODY:

This email will be logged as an email in log to case 540 because the subject contains the freeFormNoteFormat string.

See Also

Freeform Mode

Create Case

Next

Create Case
Log Email In

Did this topic help you? Email us your feedback.
Last updated: 9/19/2008 4:12:27 PM


Create Case

SUBJECT:

This is the subject

BODY:

This email creates a new case because neither the subject nor the body contain the freeFormNoteFormat string.

See Also

Freeform Mode

Log Email In

Next

API Invoke Mode
Create Case

Did this topic help you? Email us your feedback.
Last updated: 10/4/2007 11:55:52 AM


API Invoke Mode

See Also

Example Emails

Freeform Mode

Next

Log Case Notes
API Invoke Mode

Did this topic help you? Email us your feedback.
Last updated: 10/4/2007 11:53:21 AM


Log Case Notes

SUBJECT:

LOG_CASE_NOTE

BODY:

CASE_ID: 540

NOTE_STR: These notes will be logged to the case.

See Also

API Invoke Mode

Log CR Notes

Simple Create Case

Create Case

Next

Log CR Notes
Log Case Notes

Did this topic help you? Email us your feedback.
Last updated: 10/4/2007 11:56:34 AM


Log CR Notes

SUBJECT:

LOG_CR_NOTE

BODY:

CR_ID: 123

NOTES: These notes will be logged to the change request (bug).

See Also

API Invoke Mode

Log Case Notes

Simple Create Case

Create Case

Next

Simple Create Case
Log CR Notes

Did this topic help you? Email us your feedback.
Last updated: 10/4/2007 11:57:12 AM


Simple Create Case

SUBJECT:

CREATE_CASE

BODY:

THE_TITLE: This is an example of a simple case creation

SITE_ID: 123

F_NAME: Fred

L_NAME: Smith

PHONE_NUM: 512-418-2905

See Also

API Invoke Mode

Log Case Notes

Log CR Notes

Create Case

Next

Create Case
Simple Create Case

Did this topic help you? Email us your feedback.
Last updated: 11/8/2007 9:14:38 AM


Create Case

SUBJECT:

CREATE_CASE

BODY:

THE_TITLE: This is an example of a more robust case creation

SITE_ID: 123

F_NAME: Fred

L_NAME: Smith

PHONE_NUM: 512-418-2905

PART_NUM: Email Agent

MOD_LEVEL: 2.0

DOMAIN_NAME: Software

CONTRACT_ID: C12345

CASE_TYPE: Problem

PRIORITY_STR: Medium

SEVERITY_STR: Low

CASE_STATUS: Working

QUEUE_NAME: Support Cases

USER_NAME: emailclerk

CUSTOM_FIELD1: Interface

CUSTOM_FIELD2: 12345

GEN_TIME_BOMBS: True

See Also

API Invoke Mode

Log Case Notes

Log CR Notes

Simple Create Case

Next

Copyright Notice and Trademarks
Create Case

Did this topic help you? Email us your feedback.
Last updated: 11/8/2007 9:14:27 AM


Copyright Notice and Trademarks

Copyright © 2010 Dovetail Software, Inc.
All rights reserved

Dovetail Software intends the information in this document solely for its licensees and to aid prospective customers in evaluating Dovetail Software products. Any other use is prohibited. Dovetail Software makes a written warranty to its licensees, as is stated in its written license agreement. Dovetail Software makes no warranty to any other party regarding the accuracy or usefulness of the information contained in this document. Dovetail Software reserves the right to modify the content of this document without obligation to notify any party. Dovetail Software is not liable for consequential or incidental damages.

Dovetail Software develops and supplies software and customizations to the following Clarify products: ClearSupport, ClearQuality, ClearHelpDesk, ClearContracts, Policies and Customers, ClearSales, ProductManager, ClearCallCenter, and ClearLogistics.

ManyDovetail Software products use the following Clarify tools: User Interface Editor, ClearBasic Exchange, Data Dictionary Editor, ClearBasic Batch, Data Exchange, Clarify Business Objects, RuleManager, eBusiness Framework, ClearBasic, and Clarify Low-Level API©.

Clarify, its product names, and tools are trademarks of Amdocs, which may include the following: AmdocsCRM, ClearConfigurator, SalesBasic, ClearConfigurator Workshop, Notifier, eSupport, Classification Engine, eOrder Routing Server, eResponse Manager, ClearEnterprise, Email Clerk, Email Manager, Traveler, e.link, Diagnosis Engine, and Flexible Deployment.

Copyright Notice and Trademarks

Did this topic help you? Email us your feedback.
Last updated: 12/14/2010 5:57:37 PM


Dovetail Email Agent


Did this topic help you? Email us your feedback.
Last updated: 8/16/2012 9:43:54 AM


Contents Index Search